APN configuration issues for mms/data

I’m migrating from my old XA2 to a 10 III and I’m having troubles with mobile data and mms apn configuration.

MMS has always been an issue, but I use it quite rarely, so no big problem (would be great to get it running though).

But data worked without any issues on my XA2, but the same config doesn’t work on my 10 III. Weird enough, my XA2 uses a 4G connection, the 10 III only a 3.5G (same SIM card, both up-to-date SailfishOS).

This is my data config:
Connection Name: Salt Internet
Access point name: internet
Protocol: Dual
Authentication PAP or CHAP
no username
no password

This is the information for the APNs from my provider:

Am I missing something? …shouldn’t this work on both phones the exact same way? Might I need to configure something else?

about the mms apn: where do I put the "Server : " part? is that the proxy?

Thank you very much for any help in advance!

1 Like

No idea what you should do… but what i can tell you is that APN settings won’t affect what connection technology you end up with.

I’ve never seen “3.5G” on my XA2 before, so I wasn’t sure if data is supposed to work like “normal” or if that might be a reason why it doesn’t work, independent of my apn settings

This is indeed confusing. I would this combination:

Proxy address:
Proxy port: 8080
MMS message center:

and if that doesn’t work, swap the proxy and MMSC parts:

Proxy address:
Proxy port: 8002
MMS message center:

Thank you for your response. In the meantime i found out that my problems with MMS have nothing to do with Sailfish or the APN settings. Most Swiss mobile operators stopped supporting MMS in Jan.2023 (Salt. | MMS Discontinuation). I must have missed that, sorry for the inconvenience.

The same with Swisscom: Goodbye MMS: Swisscom to phase out MMS service on ... | Swisscom Community

The problem I stated above regarding my data connection Is a problem other users of the 10 III device have, too. It has nothing to do with APN settings (see: Unable to use mobile data on Sony Xperia 10 III for more details)

I re-installed android 109 on the device, erased/wiped everything and then did a fresh install of Sailfish OS. No problem since. So hopefully this was just a “glitch”.

Thank you all for your time!

Does your data connection survive a reset?

Just for my information, what happens when a swiss mobile suscriber try to send a picture from an Iphone with Messages to someone with an android phone?

Reset? It survived 10+ to/from flight mode switches and about 5 reboots without any problems. I did remove the PIN code from my SIM before re-flashing the OS, not sure if that’s still necessary (it was a suggested “fix” i tried before flashing again). I’ll test it the next days with a PIN code set, I just want to make sure it works properly first.
A lot of other people report problems regarding data connection while roaming. I should be able to test that tomorrow.

They just state that you need third party apps for that like Whatsapp, Signal or alike.

In the meantime I used roaming a few times, switched between CH/FL/A multiple times, never had any issues with my data connection. Also Restarted my phone multiple times without any issues.

But I don’t get any data connection if I secure my SIM-card with a PIN. But without a PIN code it works fine as far as I have observed.

I’d much rather not have my SIM card unsecured, but at least the phone works.