Announcing sailfishos:chum

Well, I managed now to download it by randomly tapping fields, but installation fails. I use SFOS 4.2.0.21 on XA2 Ultra

I have reuploaded RPMs to Google Drive.

Do you have the sailfishos-chum installed? You can find an RPM in this thread or at OBS.

1 Like

Done) Check my original comment.

2 Likes

Actually I don’t. I did not realize that this is required seperately. I’ll give it another try

I tried again and it’s working now. I see the available apps in chum GUI and can install apps. Thank you!

Thank you very much for it! Looks like integration plans with OpenRepos is stalling a bit and this is a very welcome addition.

We can make the repo at github for you at Chum org, just let us know the preferred name. sailfishos-chum-gui? Or something else, as just “gui”?

I presume you pull info from what was written in the SPEC. Great push to make sure that this info is adequate. :slight_smile:

2 Likes

I have no preference here. The only thing I can say - when cloning a repository just “gui” may be unclear.

Yes, only that is PackageKit::Transaction::GetDetails provides in its response.

I thought about it too :slight_smile:

2 Likes

Here you go: https://github.com/sailfishos-chum/sailfishos-chum-gui

You should have invite in your mailbox as well :slight_smile: . Looking forward!

1 Like

I created a submit request to chum:testing. Not sure if I did everything right

It is all in, but failing due to missing dependencies. See build logs at chum:testing

(writing just in case if @piggz hasn’t written already)

I have added you also as a maintainer of Show sailfishos:chum:testing / sailfishos-chum-gui - SailfishOS Open Build Service . This allows you to test the builds against Chum targets.

When you feel it is ready (compiles on all versions that you wish to support), please submit it to sailfishos:chum from :chum:testing. Then we can promote it to the regular chum repository.

Thank you for your work!

Check this Sailfish OS Chum installation :wink:

9 Likes

@mentaljam ~ I’ve followed your instructions, Chum is installed and can open it, header shows ‘Chum’ title under it says ‘Available packages’, tried reloading…but list is empty and remains empty, what am I doing wrong here?, I must have missed something…?

Try run in terminal

pkcon refresh

As for now Chum GUI lacks in features like automatic repository update or even manual update.

2 Likes

Doh!, good ol’ pkcon refresh!..how could I have forgotten that one!

Chum list now populated, thanks.

2 Likes

The page is now available at chumrpm.netlify.app. The sources are at github.com/sailfishos-chum/sailfishos-chum-web.

7 Likes

Sites moved? I’m getting a 404.

EDIT: Start at the END. Duh. Looked. Up. Thanks!

As from SailfishOS 4.3, I can’t see any available packets in chum-gui. It’s just an empty page. Reinstall didn’t help.

1 Like

Same for me.

1 Like

Its not yet officially supported for 4.3. You can try manually downloading packages from repo and install local.

1 Like