Android Support does not start [solved]

Using XA2 and the latest Sailfish version. Since yesterday, Android App Support does not start anymore, for no apparent reason. Either installed nor uninstalled anything, simply used a few apps, suddenly, Android Support does not start anymore.
Restarting the phone does not help. When I start my phone and want to start any Android app, it simply does not start, system message telling me the app will start once Android app support has started. In settings, Android App Support tells me unable to start.

API Level 30
Security patch level: 05/10/2022

Any ideas how to fix this?

Is Patchmanager installed on your device?

Have you tried to start Android support from the settings?

1 Like

I’ve noticed this. Using Xperia 10 II, no patchmanager, no edited files, just my own sailfish apps.

Even this morning, I thought Whatsapp was a bit quiet, tapped on Whatsapp icon, a pop up appeared at the top of the screen “Android is starting” (words to the effect), but Whatsapp did not open. Tapped icon again, same message about Android starting then Whatsapp did open. This is quite sporadic, mostly whatsapp stays running in background.

I have this many times, then it says it failed to start, then i start it and then it usually works, sometimes another iteration of this is necessary

What is Patchmanager?

Yes, I tried starting it from the settings, same problem.

Had this a lot with latest verions of SFOS. Simply starting android app from app grid doesn’t do the trick. Go to settings → android app support and start it from there. Still doesnt work?

Of sorry, posted right after you :slight_smile:

1 Like

This happened to me last week on my XA2.
I was unable to delete Android apps and App Support, yet could not start it.

Here’s all the steps I took, maybe one of them works for you:

I had Patchmanager installed, particularly a patch to have an Android button in my top menu. I deinstalled it all, but to no avail.

Then I tried to free up some space, as people have described App Support re-starting after that. In my case that didn’t happen.

A reflashing or factory reset usually solves this problem, but before losing all those apps and settings, I ventured to increase the root volume size, also said to bring App Support back to life, following this guide:

Everything went smoothly (Thank you @olf!), and I went from below 1 GB to 6 GB free space on the root partition (at least 1 - 2 seems to be desirable).

Nice, but no effect on App Support.

Lastly, I backed up my Android data and removed App Support via Terminal the ‘brutal way’, as described here:

This time App Support was gone for good, and after reinstalling it from the Jolla Store, it worked again!

So I had to delete the Android side, but could at least keep all Sailfish apps and settings.

This might have worked without the root partition meddling, but I included it for transparency.

Good luck!

Awesome, thank you! Freeing space on my device solved the issue.


What type of memory was released (home/user or root/system)? How much memory does Aliendalvik need?

I did need to flash my phone (xperia 10iii), because I was stuck on and the update to .21 or now .24 wouldn’t even start downloading.
I thought about recovery reset, but developer mode didn’t work either and so I wasn’t able to access this method.
So my only option was re-flash the device, using the latest .24 version.
Before doing that, I did a backup and after flashing I restored the backup successfully.
However, android support doesn’t start now. I can install it from jolla store, but the information in the settings menu always sais ‘cannot start’. It doesn’t change how often I press the ‘start’ button.
It also stays the same after reboot.
I also did uninstall it and removed it via the ‘brutal way’ method, according to jolla docs.
After a reboot and a new installation from jolla store, the issue persists: Android app support cannot start.

Again, the device has just been refreshed via flashing. What can be wrong after that and how to fix this?

As I thought about the whole process again and again, I remembered that I needed to boot the device twice after flashing. After the first boot, screen went black at the step of encrypting user data. Since it didn’t change for sevaral minutes, I forced the device to reboot and then everything was fine on a second attempt. Maybe something went wrong there.
However, I decided to re-flash it again und as everything worked fine with the first boot, I have no further issues. Android Support is now working.
Hope this is useful, whenever someone experiences the same glitches…

1 Like