Android problems after Update to 4.5

OS VERSION: (Struven Ketju)
HARDWARE: Sony Xperia XA2 Plus (dual SIM)


Android stores that worked before have no access anymore, and .apk cannot be installed from the Downloads folder anymore (“not allowed”)


Updated to EA flawlessly when it rolled out, needed an OTP Authenticator from either FDroid or Aurora store.


  1. Updated to EA
  2. Open Android store (FDroid or Aurora)
  3. alternatively, download .apk directly and try to install it per “Install” rolldown menu point in File Manager


Either Stores connecting to the internet and showing their offers, or SFOS letting me install OpenOTP directly from the downloaded .apk in the Download folder.


Both FDroid and Aurora start up, but cannot establish connection (neither WiFi nor Mobile Network) although other Android apps work as intended (Whatsapp, Instagram etc). Both show the error message “Unable to resolve host [url here], no address associated with hostname”, which for me is a sign that they are cut off from the internet. Also, when I try to Install the .apk file I downloaded via Sailfish Browser from the Download folder, I get the message “not allowed”.


Patchmanager, Tor for SF Browser



I’m having issuea with Deezer, but that seems to be issue with Deezer, since the issue appears with native Android too…

Fennec can’t access some/many sites, there’s no rhyme or reason to what works and when. Vivaldi and Browser work fine.

I’m using IP (IPv4) only for my mobile data, but the same issues occur with IP+IPv6 too…

I try again with WLAN, perhaps my DNS server log reveals something…

For me it works - both, Aurora and FDroid, with Xperia 10ii and Xperia 10iii and SFOS 4.5

For me it didn’t allow connections on wifi in android. I turned it on in android settings and it turned itself off when i went back to the setting… Mobile data works fine, at least.
edit: now it works in WiFi too, don’t know what it was

I am glad it’s working for you too, now! (And that it’s not a serious bug)

Add-On: when I check the Android settings (tapping multiple times on the Android version number) it shows both of my WLAN connections as “No Internet”, but with perfect signal strength and upload/download speed. Also, there’s nothing about the mobile network settings that should keep my phone from using this way for data transfer.

As written above: although there’s the “No Internet” label, the social media apps work although they shouldn’t.

I’m completely helpless here. What and where should I check?

When the system doesn’t want to install apks, could that be because of the ‘Untrusted Software’ option in settings? When disabled, I cannot insall apks from storage (/downloads).
Have you also tried to restart android app support, and ‘network’ from settings (the latter requires the utilities app). Or maybe even restart the device?

For me (10 II), the connections work as they should.

The apk installation didn’t prove to be problematic later - instead of “install” I tapped “open” which installed it flawlessly then shrugs

The more problematic part, even after restarts of Android, ofono, phone, is that the Android settings say “perfect connectivity” but at the same time “no internet”, leaving me without updates, banking and work login credentials but still providing me with social media.


I am having the same issue after the update. I’m on an XA2 as well, no modifications. When I updated it, the update progress was stuck at 100% for half an hour, and the power button was not enough to restart it, I had to use Volume up + power.

Then it booted and migrated apps, but now the internet connectivity is as you describe: sporadic in that some apps work (e.g. Messenger) and some don’t (e.g. Aurora Store, banking apps). Some might work partially (F-Droid shows something at first, but then it says no internet).

This is actually not limited to Android apps! If I go to the Sailfish OS Updates settings page, it also says that it cannot check for updates because it’s not connected to the internet. If I tap on the bubble, it gives the connect interface, which however shows that it’s connected just fine!

Restarting the internet using Sailfish utilities does not help.

Are there any suggestions as to what can be done now? Should I reflash the whole OS or so?

Same problems after an otherwise smooth update on XA2 - all Android apps are air-gapped, including Aurora Store, Firefox, NewPipe.
Notable exception: Tor Browser is working fine.
Android Settings indicate a strong WLAN signal yet “no internet”.

And now the issue solved itself! Very strange. Perhaps because I connected to a different access point. Android settings now show the AP I am connected to.

I had the issue with Mulch browser (Chromium fork by DivestOS). There, I had Secure DNS enabled, which works fine inside Wi-Fi networks. But outside with mobile data, no hosts where resolved with that option enabled.

I have found another (maybe related) coincidence: the three apps that still have online connectivity (WA, Insta, Briar) are all located inside /home/nemo/android-storage/Android/media ( and no other apps). Before the update, they had their respective folders in /home/nemo/android-storage. So here’s the new question: how is the android-storage/Android/media folder treated differently from the android-storage mother folder? And if it is the (still dirty) workaround: how do I get the other apps that really need internet connectivity into the Android/media folder?

I cannot confirm this distinction.
In my case, all Android apps are in home/defaultuser/android_storage/Android/data
(none still in /nemo btw)
Most have no connection to the internet, but some (like Signal or Tor) do.

1 Like

Hm, another escalation - originally, Instagram worked although other apps already lost connection. Today Instagram wasn’t able to load pictures and videos, but displayed texts correctly. After experimetally clearing Instagram’s cache and app data, I am not even able to log in because of lack of internet. It looks like Instagram literally had some sort of tunnel which collapsed when I erased stored data :confused:

For me, with Fennec the fix was to go to about:config and disable IPv6 from the DNS. (Search for dns and it pops right up.) Thabks for pushing me to that direction!

Now, how to make Deezer work like that…

Hm, yes, that makes sense! The first AP I used had IPv6, but the second one did not. So probably the ipv6 stack is broken and nobody even noticed until now…

Yeah. Telia/Finland doesn’t support IPv6 at all over SIM card, so no wonder I can’t get anything work here…

So… if IPv6 is the culprit, is there a way to disable IPv6 system-wide (or rather AppSupport-wide)?

This is above my pay grade, unfortunately, so I would be thankful for any hint.

Certainly, but it seems that just disabling ipv6 doesn’t actually solve the problem for some reason. I tried changing the ipv6 preferences in /etc/gai.conf, in sysctl (even making it persistent by making a new file in /etc/sysctl.d), even manually flushing the ipv6 address with ip -6 addr flush wlan0, and yet the apps (including the Sailfish settings app) still can’t connect to the internet. This is very odd.