Android IKO app does not start from app grid

REPRODUCIBILITY: always / 100%
HARDWARE: Xperia 10iii
REGRESSION: new issue


Recently I’ve upgraded to 4.6, before upgrade IKO worked flawlessly, but after upgrade, it started behaving as follows:

  • when I start IKO app (pl.pkobp.iko, polish banking app) from an application grid, it starts, but when splash screen changes to login screen, app crashes/closes.
  • when started from eg. aurora shop, using “open” button, it works, just as it used to before upgrade.

Logcat does not show anything related to IKO, but journal gives such a “hint”:

cze 10 14:03:09 Xperia10III kernel: qcom_rpmh DRV:apps_rsc TCS Busy, retrying RPMH message send: addr=0x30010
cze 10 14:03:12 Xperia10III booster-qt5[5298]: *** signal=17 pid=5298
cze 10 14:03:15 Xperia10III kernel: qcom_rpmh DRV:apps_rsc TCS Busy, retrying RPMH message send: addr=0x30010
cze 10 14:03:19 Xperia10III kernel: [schedu][0x5699df41a2f][12:03:19.622592] wlan: [9868:I:OSIF] scan start scan id 41475
cze 10 14:03:21 Xperia10III invoker[16220]: Launching Android Intent android.intent.action.MAIN pl.pkobp.iko/pl.pkobp.iko.feature.startup.StartupActivity
cze 10 14:03:21 Xperia10III lipstick[13102]: [D] unknown:0 - Specified Desktop file does not exist "/usr/share/applications/system_server.desktop"
cze 10 14:03:21 Xperia10III invoker[13276]: WARNING: An inactive plugin is misbehaving - tried to show a window!
cze 10 14:03:21 Xperia10III invoker[13276]: WARNING: requestActivate() called for  QQuickView(0x12f36b10)  which has Qt::WindowDoesNotAcceptFocus set.
cze 10 14:03:21 Xperia10III booster-generic[5296]: *** signal=17 pid=5296
cze 10 14:03:21 Xperia10III /usr/libexec/mapplauncherd/booster-generic[5296]: warning: Daemon: sending exit(0) to invoker(16220)
cze 10 14:03:22 Xperia10III kernel: pm7250b_charger: somc_aicl_irq_handler: IRQ: aicl-done


SFOS up and running, AD running.


  1. goto app grid, tap on “IKO” app icon.
  2. wait
  3. crash


login screen appears


login screen does not appear, going back to main screen


nothing fancy some patches


Was it installed before updating to 4.6.0? If so, you may have to remove the app and install it fresh. That’s what I had to do with a few of my Android apps.

Edit: While reinstalling fixed the apps for me, it doesn’t mean there’s no bug here in my opinion - there is one.

1 Like