Android file dialog

REPRODUCIBILITY (% or how often): always since update to
HARDWARE (Jolla1, Tablet, XA2,…): XA2 Dual SIM
REGRESSION: (compared to previous public release: Yes, No, ?):


Since the update to Rokua,, I can no longer save files under Android. I have one app running in Android, where I enter substantial amounts of data and want to run regular backups. After selecting backup in the app the file dialog opens and I can navigate the folder system and even create a new folder, but there is no button or menu choice anywhere to save the file, not even to close the dialog. The dialog is a separate window on the home screen and can be closed from there. Therefore it appears to be - as it should be - a system based dialog and not part of the app.






(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

Welcome to this bug. I guess you can’t load files either?
This is a known bug and is supposed to be fixed in version 3.4.

We will fix the access of Android apps to the file system (including the SD card) in OS release 3.4.0.

1 Like

Thanks for the quick and concise answer. Sorry for the duplication, I could not find the previous threads via search.

Absolutely no need to be sorry. Jolla made the decision to start this forum and leave TJC hanging around besides.
Let’s see for how many more months???

1 Like

hm, I still have this issue under 3.4 with k9 mail 5.721.
Honestly I didn’t go through all the 522 reported issues on github for this version, so maybe somebody can confirm and/or advise?

Hmm, for me it is fixed now in

I have started from scratch with a fresh OS.

So did I. On the last time I tried to save something it worked as it should… hm.