Android App Support Has Stopped Functioning! [SOLVED]

Hello Fellow Sailfish’ers -

Sailfish Sony Xperia A2 Ultra

This afternoon Android® App Support stopped functioning! On the Sailfish page, next to “App Support” I get the message “unable to start”.

I reverted to my last backup - which was about a week ago - when I updated to “Struven ketju” Sailfish - but Android® App Support still does not function.

If this continues, the device is basically useless to me. Has anyone had a similar problem? Does anyone have any suggestions as to HOW TO RESTORE FUNCTION to Android® App Support?

Hoping for help from the Sailfish Community . . . :crossed_fingers:

  • Mehermuchacho

Backups has absolutely no bearing on this.

A few weeks back App Support had stopped and didn’t start on app launch. I had to start it from its settings page, and then it worked fine.

If you haven’t - reboot. Then check the journal log for errors.

Thank you attah. I have already re-booted once at least. I also tried to START the app manually on the page that comes up via the Settings page. This is when I’ve received the message “unable to start”.

I don’t know how / where the “journal log” is to check for boot errors / error messages. If you can point me toward it, I’d be most grateful.

Meanwhile I’ll try again to reboot and hope it launches on boot-up.

It just stopped functioning in the middle of working today. Whatsapp or Telegram was playing a message, then SILENCE, then Whatsapp / Telegram closed.

Thank you for replying so quickly, btw - I appreciate it greatly!!

  • Mehermuchacho

p.s. I have tried re-booting, and have toggled the “Start Android® App Support on startup” button on the Settings page before re-booting, but the problem persists…

Are you by any chance running low on storage?

Actually, yes . . . !!

If it’s less than 300~800mb (I can’t remember precisely when it’ll stop working) try freeing up some space. Android app support for some reason can’t start at all when you’re that low on storage.

I have recovered a root free space up to 812MB so far and AppSupport stiil doesn’t start.

I also have this problem on occasion with Xperia 10II. Plenty of free space (system data) @ 1.8GB (3GB used) with 89.7GB storage space.

Did it ever start correctly after updating?

Perhaps you have an incompletely updated device. (It happens, especially if system disk space is low ehen updating.)

Hello, All -

Thank you again for your help and useful suggestions. I went into

SETTINGS>STORAGE>ANDROIDstorage>ANDROID>“media”>com.whatsapp>Whatsapp>WhatsApp Video

  • and I deleted every video I’d sent in the past two years. This free 'd up about 1.8 GB, and when I re-booted, Android® App Support started perfectly and I had Whatsapp and Telegram once more.

Thank You All So Very Much!! [SOLVED] !!!

  • Mehermuchacho x x

Don’t hold your breath. Did you read last my comment?, I have 1.8GB the same amount of space you’ve freed up, but still, periodically, I find Whatsapp won’t start as Android Support has disabled itself, I don’t believe this has much to do with free space, but as with any of us, it is a case of speak as you find.

Thanks, Edz - I’ll bear it in mind!! I’m going to do my best to delete a lot of other stuff, too, when I can grab the time, in the hope that it is simply a Storage problem.

Thanks for the follow-up - I appreciate it !!

  • Mehermuchacho
1 Like