Android app (Signal) - how to prevent it to run in background

I am using Signal app. And it somehow runs always in background. Whenever I connect to internet, it starts loading conversations.
I would like to prevent it. I uncheck possibility allowing service in background, but without any change.
Sony Xperia (XA2 Dual Sim).
Do you have any idea ?

this (and other) privacy stuff in android layer should be builtin in SFOS

Yes. That was discussed earlier.
And the only way to suppress any Android app to autostart itself is to disable Android Support!

So this should really be prevented by SFOS when ‘background services’ are disabled for a specific app.

so it is then bug.
Should we report that ?

why should be signal written inside SFOS ?
Isn’t enough to run it as android app ?

Hello - I will test an optimizer tool. This can close automatically (every 30 min or longer) all android processes with a withe list. Tomorrow I know more…

One day later - it works for me. Only the android apps on the white list are active now. Now I change the interval of 2h.

you didn’t understand what I wrote

You could forbid background services for Signal in Settings:Apps:Signal

1 Like

or turn off Android support if not needed?

1 Like

yes, I didn’t. Maybe you can describe it a bit more

If you check and read my post again, you will see I uncheck this option

then I cannot start Signal at all

Android support should start automatically if you start an Android app

Then you might consider checking the Android permissions.

1 Like

Yes, you are probably right and it is worth a try. This behavior has been observed since SFOS 3.0. The checkbox (not allowed in the background) has no effect when the app sends notifications. Sometimes all notifications of the corresponding apps have to be switched off so that they no longer run as a service.

Of course you can ask yourself why the checkbox in settings / apps has no function. If I remember correctly, it came with the change of the Android runtime from J1 to Sailfish X. I also see the bug on the XA2, but not on the J1.

This is unfortunately a long existing bug and still exists in 4.3 and I hope this gets resolved with 4.4

I am using a whatsapp->matrix bridge (element one), but need whatsapp installed to set up the WA account and login every 2 weeks or so to not get the account blocked and experience the same issue. I’ve now disabled all notifications (Android Settings) for WA, so at least this shitty program doesn’t bug me.

This works.
Thanks a lot.

1 Like