Android App DB Navigator not working since Update to 4.5

i am using the app db navigator on a daily basis. For the last month or so the app became more and more unstable. To book a ticket, I had to go back and forth several times. But it worked. Since the update to 4.5 the app does not work anymore. The booking process just stops somewhere. What I did already try: Remove the app and reinstall a previous version. It got worse. I even can’t login to my account. Could there be any problem with the app triggering the browser to open? Because a login in the db app in principle requires a login via browser, but the browser is not opened.

Since there are some users from Germany, could you share your experiences or do have a working set up?

Any help is appreciated.

My phone: XA2


I don’t buy tickets with DB navigator, because I don’t do payments on the phone for security reasons. But I am using DB navigator regularly for anything else and it works just fine on my 10 III. I had trouble to login via the SFOS browser in the past. At some point I installed Vivaldi and made it the default browser which solved any login problems (also for other apps).

Not sure how this can help you just so you know that DB navigator is usable with SFOS.

Good luck!

– Reiner

Hello Reiner,
thank you for your response. I had the issue with login in the past. But this time the problem is different.

What does work: Opening app, running app, using app to schedule trips

What does not work:

  • Login into user account
    • In the past there was an Issue with login, because the app had problems to acknowledge the browser
    • With 4.5 the issue is that after clicking on login the app shows no response at all (no browser opens to enter login credentials)
  • Booking a ticket: the process stops in between with a whitescreen

I see. The only thing I can think of is to check the “Open by default” group in the app’s Android settings and make sure that it has permission to open supported links and is among them.

If this looks alright, someone else, who is more knowledgeable than me, might be able to point out which log files one should check.

AFAIR I haven’t bought new tickets wit DB-Navigator on 4.5., yet. (XA2+) Also, I didn’t have to login on 4.5. However, loading tickets, comfort check-in, ‘real-time’ timetable, etc worked without issues.

Try FireFox-Browser (Android) as default browser. :wink:

1 Like

Sorry, I don’t understand. Do you mean I should use Firefox instead of Navigator?

Yes, I also installed the FireFox browser. The forwarding of DB-Navigator works with FireFox. With the SFOS browser I only get a white display and the transaction breaks off.

1 Like

Apparently you need an Android browser installed to handle the log-in request from the navigator app within the AndroidApp Support Container. The release notes for 4.5 mentioned changes in the AAS security architecture, that might be the reason for the change.

To clarify this more explicitly, your problem is that the DB navigator App opens the Browser for login. The aliendalvik default is the preinstalled, SailfishOS-native browser. Which, at least for me, never worked for this.
To fix this, install Fennec from F-Droid, then goto the Android settings of Fennec and set it as default browser inside of Aliendalvik. Afterwards, you’ll use Fennec for login and it’ll work fine.

1 Like

This was already the case with 4.4 for sure.

Thank you all for your support. I really got it to work. First I was disappointed about the responses. Because my problem was definitely a different one than the old ‘browser is not handled correctly’ issue. And I did already have an android browser (opera). But after installing firefox, i was able to select one of the browsers to enter my login data.

1 Like

No, this was NOT the problem. DB Navigator did not open any browser. After a click on login simply nothing happened.

So the mime handler was broken?

1 Like