Android app connectivity unreliable / using incorrect carrier

REPRODUCIBILITY (% or how often): random
BUILD ID = OS VERSION (Settings > About product): 4.2
HARDWARE (XA2, X10, X10 II, …): XA2, 10
UI LANGUAGE: Irrelevant
REGRESSION: (compared to previous public release: Yes, No, ?): Yes


Since 4.2 Android apps either randomly lose connectivity, or stubbornly keep using 4g when started (even when wifi is available). It seems to be somewhat related to switching between 4g and wifi (e.g. entering and/or leaving the house).

When the connection works but is incorrectly using 4g, the android apps are aware they’re using 4g. Apps like ApkPure will ask to confirm download over cellular connectoin.


No exact idea


  1. Start the phone
  2. Wait
  3. Notice android lost connectivity


If sailfish has internet connectivity, so should the AlienDalvik support.


It often just stops working without any notice


(Please ALWAYS attach relevant data such as logs, screenshots, etc…)


Haven’t been able to trigger this in 4.3 anymore. I guess this is solved. Anyone else still run into this?

And it just happened again in 4.3. So this bug is, unfortunately, still not solved. ApkPure reports a “Network Error” which persists until Android Support is restarted. Turning wifi off and then on again did not help.

1 Like

Thanks for the report. We will do our best to eliminate this issue.

I can’t reproduce this behaviour on my XA2 Plus dual sim with 4.3

Interesting, that’s the exact same model as I have. TBH it’s not happening as frequently as it did before with 4.2, but it still sometimes breaks. Internet works fine in native apps, but not in Android.

I can confirm that connections still break maybe less than previous releases but still present.

For me it happens almost daily now. When I turn off flight-mode in the morning when waking up, the phone connects to both wifi and 4g. Then I see the icon switching between the two.

At this point, Android is using 4g while native apps use wifi. If you turn off 4g at this point connectivity breaks.

This report got marked as “fixed” by @flypig, while it most definitely is not. Seems like I cannot edit the post anymore. Can somebody please remove this tag?

1 Like

Hi @martijntje. You’re probably already aware, but just for context, this was closed due to the process I described in this post.

In this case, the bug was listed as having been fixed in 4.4.0, as you can see in the release notes. Looking at the internal bug report, I can see there were several changes made to fix this, including this PR.

Would you mind clarifying whether the bug — e.g. the situations it arrses — are identical to those you wrote about in your original bug report? I can create a new internal report about it, but any additional info you can provide would be really helpful, especially given this was tested internally and found to be fixed.

Not sure if this is exactly the same, but my XA2 on 4.4 still regularly loses connectivity for Android apos only - specifically when moving between WiFi and mobile data. A reboot fixes the issue and sometimes (though not always) restarting the network using Sailfish utilities. There is no indication that connectivity has failed - you only know when you try to use it from an android app and couldn’t, or after you restart and suddenly get loads of WhatsApp or Facebook messages from hours or even days ago. Its a real pain.

1 Like

Yes, the bug has remained the same. The steps from the post on 15 January still work to easily trigger the bug. The last few weeks I’ve mostly been working with wifi disabled since 4g is mostly fast enough. With wifi turned off the connectivity never breaks, so it’s definitely related to wifi.

Okay, thanks both for confirming this is still an issue for you.

I’ve created a fresh internal bug report about it and removed the “fixed” tag.

1 Like