AlienDalvik Android issues on 4.0.1.48

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): 4.0.1.48
HARDWARE (XA2, Xperia 10…): Xperia 10 Plus
UI LANGUAGE: US English
REGRESSION: (compared to previous public release: Yes, No, ?): ?

DESCRIPTION:

On a fresh install of 4.0.1.48 on my Xperia 10 plus, I have been experiencing issues with Android apps not registering features properly and occasionally crashing. These are some of the problems encountered:

  1. After enabling Android app support and disabling package verification, I installed microG and its dependencies, then stopped/started AlienDalvik. Once that was done, the microG self-check shows that the system does support signature spoofing, but that it is not currently enabled. I have dug through every Android permission I could find, but there did not appear to be any way to grant spoofing permission to microG.
  2. HERE WeGo maps is unable to connect to the internet at all, and therefore does not function.
  3. Maps.me was able to download its maps, but intermittently has trouble connecting, and often cannot obtain my location.
  4. AuroraDroid kicks back to the home screen whenever a search is performed.
  5. Cash App does not permit device registration.

PRECONDITIONS:

None

STEPS TO REPRODUCE:

  1. Flash Andorid 9 with Emma
  2. Flash Sailfish 4.0.1 from official images
  3. Start Sailfish and register Jolla account
  4. Install Android support and disable package verification
  5. Install microG
  6. Restart Android support
  7. Open microG self-check and review app functionality

EXPECTED RESULT:

  1. Signature spoofing should function.
  2. HERE WeGo and Maps .me should be able to connect to the internet and obtain location.
  3. Cash App should allow device to register.

ACTUAL RESULT:

  1. Signature spoofing does not work in microG.
  2. HERE WeGo and Maps .me cannot talk to internet and have trouble obtaining location.
  3. Cash app does not allow device to register.

ADDITIONAL INFORMATION:

I am willing to provide logs, but not sure where the relevant logs are stored.

1 Like

Are you maybe running in to this:

It is solved by linking the old nemo home directory to the new defaultuser home directory.
No idea how finicky Cash App is about things like SafetyNet etc, so that might be a feature of that particular app rather than an issue with Sailfish. But see what happens when you get spoofing working.

@attah Thanks for the link. That chain of threads was very confusing to follow, but it allowed me to make some progress with microG. Here are the steps I followed:

  1. Factory reset Sailfish.
  2. Set up phone and Jolla account, but don’t install Android App Support
  3. Enable developer mode.
  4. From terminal, run devel-su, then ln -s /home/defaultuser /home/nemo
  5. Install Android App Support and enable signature spoofing.
  6. Install F-Droid, update, install microG and Nonolx repos, install microG
  7. Grant the enable system package replacement permission and all other permissions to microG apps from Android Settings.
  8. Stop and start Android App Support
  9. Open microG settings and verify that self-check shows everything is ok

However, from this point I noticed that apps are still having trouble communicating with the network. microG has trouble registering my Google account, and gives the error There was a problem communicating with Google servers. Try again later. I had not previously attempted registering my account, so this very well could have been an issue before as well.

Additionally, HERE WeGo still can’t talk to the internet. Something is messed up with network access from the AlienDalvik container, but its not clear what since other apps can talk to the internet.

Any ideas on how to troubleshoot further?

I’m not sure you’d want to do that. Do you really need it?
If you do, maybe look into getting the actual Google Play Services (i think i saw that working somewhere).
I assume this is more of an issue with microG and Google than something specific to SFOS, but as i said, i haven’t tried.

Is HERE we go the only app with network issues?
Maybe you got a bad/old version? I just installed it, and it works just fine.

@attah I do have a few purchased Android apps that I’d not like to lose, which is part of why I’d like to have microG logged in. The other part is trying to get to the bottom of why it’s having trouble connecting, as it may be related to why HERE WeGo is having trouble connecting. On my device, HERE is the latest version from Aurora Store, so it’s not an old version, nor is it the only app with connection issues.

Aha, of that i have no experience. The countless resources (mainly for custom Android roms) out on the internet will be a better source for what combination of what play services (substitutes) can make that happen than my speculations.

I installed HERE that exact same way… strange. (and on a basically completely fresh install at that)
To gather logs from the Android runtime, you can use this command:
lxc-attach -n aliendalvik -- /system/bin/logcat

Maybe something sticks out…

I have freshly installed 4.0.1 on xperia 10 plus, with payable sailfish, but I cant find this:

  • Grant the enable system package replacement permission and all other permissions to microG apps from Android Settings.

Where is this setting?

Argh found it!

For all following my steps:

Under microg settings (not application settings but microg internal settings, you open the first menu (that checks the system for compatibilty) and just press on unticked rows. It will trigger asking for permissions.

I confirm that on the latest OS Here WeGo is not working at all. I’m on a Xperia XA2 4.1.0.24 freshly flashed