Alien Dalvik crash related oddities and maybe a question

I don’t know is there any point writing this but I’m just completely baffled - and all in all this more of a “chit chat” than anything else. Not sure if this kind of formats and topics are discouraged.

Background: Sony XA2, Sailfish (haven’t had the willpower to update yet), me being maybe in the category of “Mundane-Poweruser” but has lot to learn about Sailfish and Linux in general.

I was updating some Android apps(like Duolingo, Telegram, Signal…) on Aurora Store as you might do. I happened to ran out of space from the internal storage - I had accumulated a bit too much of videos and files through Whatsapp, downloads and by my own camera recording etc. No biggie, I move the important stuff on to my computer and remove bunch off unimportant videos, pictures, pdfs etc. I also set my camera to save files on the sd card instead of the internal storage.So I continue updating the Android apps. All goes pretty well, few apps do not seem to manage update, like Ticktick todo app, but that isn’t anything new. The updating usually isn’t flawless process anyways.

While installing the Outlook update, the UI crashes apparently along with the Alien dalvik resulting that no Android app wants to start, Alien Dalvik app support in the settings (whatever it is called) doesn’t let me either to start nor stop, both buttons being greyed out. Also I can’t connect through the phones hotspot with my computer, however Sailfish apps can connect.
I try systemctl start aliendalvik.service from the terminal but it timeouts. I try to uninstall Outlook from the UI (if that is, for some reason, preventing something) but I can’t. I start looking for a way to remove Outlook manually but before that I opt for uninstalling and installing Android support in Jolla store. I do that, restart, no changes to the situation. I uninstall Androind support again. I decide to also uninstall Aliendalvik Controll from Storeman but that gives me an error, something about “urischeme” MIME-type and “Failed to stop aliendalvik-sd-mount service: Unit Aliendalvik-sd-mount service not loaded” error. Ok, so now Storeman can’t really decide whether Aliendalvik Control is installed or uninstalled, and I’m unable to do neither, thought I have the option to try - installing gives an error "package not found". I still see Aliendalvik Control in the settings menu, can open it but I can’t access Android Settings (the only thing I tested).

Moving on, I still try to search instruction how manually remove Outlook completely, but out of the blue I get notification by Outlook that I have some new emails. I’m very confused at this point, some other Android notifications appear as well. I check Jolla stora and Android support seems to be uninstalled, I install it but it finishes very quickly and states that it’s now installed. Hotspot worked now as well. All Android apps seem to open and honestly, they are snappier that before! I think the better performance might be because I might have had Android apps installed on SD card and now they are on internal storage - I’m not completely sure, I got my XA 1½ years ago (I think) played around with and I ended up staying with my then Android phone for few reason but last summer made the switch for everyday use - so who knows what I initially did back then when I got the phone. Aliendalvik Control seems to work fine too.

Thus, I continue updating the Android apps and everything goes smoothly. One very odd thing is that Signal app has disappeared from the app drawer. Aurora store sees it and gives an option to update it. I’m not sure if I want it back, maybe that was the culprit - and regardless it has seemed to a be a very power hungry app on my XA2.

I’m just baffled and this isn’t really that important but if someone could give me some insight or ideas on what happened, I’d appreciate it because I want to learn.

edit: I do have Ui-themer installed.

Well, the issue resurfaced after updating to SailfishOS, albeit starting point was somewhat different: I tried to install back the theme I have used in ui-themer. I couldn’t restart homescreen from the ui-themer (or anywhere else for that matter). Anyways pretty soon I had issues with Alien Dalvik and I couldn’t resolve it by doing pretty much the things I did last time.
However I noticed that I had both aliendalvik-control-9.3.0-1.armv7hl and aliendalvik-control-9.3.1-1.armv7hl. I can uninstall the latter with rpm -e --noscript but not the former. I think this might be causing the issue…maybe. Any ideas how to remove aliendalvik-control-9.3.0-1.armv7hl?
(I posted this question in the Aliendalvik-control’s openrepo comments as well.

Though the ui-themer can be the issue too but I wouldn’t want to lose that as there isn’t currently way to install back AFAIK.

Ok, well, I reinstalled Aliendalvik and then checked:

[nemo@Sailfish ~]$ systemctl status aliendalvik.service
aliendalvik.service - Alien Dalvik
Loaded: loaded (/usr/lib/systemd/system/aliendalvik.service; enabled; vendor preset: enabled)
Drop-In: /usr/lib/systemd/system/aliendalvik.service.d
Active: failed (Result: exit-code) since Mon 2021-05-17 19:02:44 EEST; 8min ago
Process: 17623 ExecStopPost=/usr/sbin/ (code=exited, status=0/SUCCESS)
Process: 17621 ExecStopPost=/usr/libexec/lxc/lxc-net stop (code=exited, status=0/SUCCESS)
Process: 17619 ExecStartPost=/usr/share/harbour-themepacksupport/service/ (code=exited, status=2)
Process: 17571 ExecStartPost=/usr/sbin/ (code=exited, status=0/SUCCESS)
Process: 16572 ExecStart=/usr/sbin/ (code=killed, signal=TERM)
Process: 16570 ExecStartPre=/usr/libexec/lxc/lxc-net start (code=exited, status=0/SUCCESS)
Process: 16569 ExecStartPre=/usr/sbin/ (code=exited, status=0/SUCCESS)
Process: 16568 ExecStartPre=/usr/bin/ (code=exited, status=0/SUCCESS)    Main PID: 16572 (code=killed, signal=TERM)
Memory: 1.8M
CGroup: /system.slice/aliendalvik.service

So, UI-themer then? If so, any ideas whether this can be solved without removing UI-Themer?