After upgrade to 4.0.1.48 system wants to downgrade to 3.2.1.20

Hello. After upgrading to Version 4 the System Update Tools wants to downgrade to Version 3.2.1.20.
I have upgraded the system via ssh terminal by pkcon, because the stack update tool did not find any update/upgrade for version 4. How can I get rid of this downgrade request of the system update tool?
Thank You

Let it do it :wink: (I am also still on 3.2.1.20!). :smiley:

No, serious.
How exactly did you upgrade?
pkcon itself is not enough to do so.

Much better/safer would have been to use olf’s sfos-upgrade.

Would you please post output of
ssu s?

First I added a repo for flatpak via devel-su. Then devel-su pkcon refresh. Then the system upgrades to 4.0.1.48 and installs flatpak-runner and its dependencies. No warnings, no errors. After devel-su reboot the phone restarted as expected and the system was upgrade to 4.
Output:
Last login: Sun Mar 7 09:11:19 2021 from 192.168.2.XXX
,—
| Sailfish Mobile OS RUS 4.0.1.48+omp0.1.3.49 (Koli)
'—
[nemo@Sailfish ~]$ ssu s
WARNING: ssu.ini does not seem to be writable. Setting values might not work.
Device registration status: not registered
Device model: INOI R7 (p4903 / P4903)
Device UID: XXX
Release: 4.0.1.48
Domain: sales
Brand: Jolla
Sorry, the version ist 4.0.1.48, not 18!
I can mention, that it was not my intention to upgrade the system. I only wanted to install flatpak and it’s dependencies.
Now I ran sfos-upgrade, reboot an ran devel-su post_sfos-upgrade without warnings or errors. Output:
devel-su ssu s
Password:
Device registration status: not registered
Device model: INOI R7 (p4903 / P4903)
Device UID: XXX
Release: 4.0.1.48
Domain: sales
Brand: Jolla
But the system upgrader wants to downgrade to 3.2.1.20. Before the installation of flatpak i used 3.4.0.24.

That sounds quite strange.
I have no experience with flatpak (nor OMP, INOI devices) and would not have assumed it has some dependencies to force the system to upgrade? (probably not a full upgrade? and you were lucky system booted?)
Maybe @rinigus (or @coderus) et al. can say something?

What version is written in system settings - about?

I guess you should go with sfos-upgrade and let it do finalize the upgrade?
But before I would wait for some more insights…

Thanks: See last post. I ran sfos-upgrade, reboot an ran devel-su post_sfos-upgrade to complete a possibly not finish upgrade without warnings or errors. Output: devel-su ssu s
Device registration status: not registered, Device model: INOI R7 (p4903 / P4903) Release: 4.0.1.48
Nothing was additionally downloaded or install, so I think it was a not intented full upgrade !!
System settings/About: BUILD ID = Sailfish Mobile OS RUS 4.0 4.0.1.48+omp0.1.3.48 (Koli)
HARDWARE (XA2, Xperia 10…): INOI R7
UI LANGUAGE: English

4.0.1 sfos is not yet enabled for Inoi, so it always suggests latest available version :slight_smile:

1 Like

Oh ok. So the not intended upgrade is no good idea. Now contact syncing failed since this upgrade. I must reset the phone to factory settings and update to 3.4. So be carfeful to install flatpak-runner, because it forced an un-indened upgrade! Thank You very much.

OBS has been recently updated and flatpak-runner has been automatically rebuilt against the latest version. This probably triggered new dependencies from 4.0.1.

Looks like flatpak OBS repo is not in the bestest of shapes, some packages fail to build. Haven’t seen it before and I am not sure when I will get to fixing it.

3 Likes