After boot wlan access point turns into client

REPRODUCIBILITY (% or how often): 100
BUILD ID = OS VERSION (Settings > About product): Since many versions and now current
HARDWARE (Jolla1, Tablet, XA2,…): XA2
REGRESSION: (compared to previous public release: Yes, No, ?):
? (if yes then long ago)


If wlan is in access point mode after boot it will turn into a client


Wlan is used as access point


  1. Reboot device


Wlan can be used as an access point without changing the settings


Wlan comes back in client mode and has to be manually put back into access point mode.


(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

What makes you think this is a bug?
Sounds like intended functionality to me.

In what scenario is that useful?
For me it goes like this:

  1. Where I work we have a wifi that is so slow it’s useless. If I need to use my laptop I put my phone in access point mode. Then if the phone runs out of battery (or boots for some other reason) it’s in client mode when it returns and connected to the worthless wifi.
  2. When I drive the car is connected to the internet trough the phone (for traffic flow reports and rerouting). If the phone boots I need to stop the car and reset the wifi into access point mode or, if it isn’t possible to stop, surf through the setting menus while driving.

As tethering may result in data charges or using up your data allowance, there is a good argument to be made that tethering should not be activated without deliberate user action…

It may be possible to for you to change the connman (that’s the service that manages network connections) config so the tethering state is persistent across reboots.

(See section on tethering)

Tethering being sort of a twice-a-year use case for most people, and having it enabled interfering with normal client use of the phone makes me believe this behaviour is intentional. It is probably the default/normal mode in the drivers too. It might not be entirely optimal for all cases, but it also doesn’t sound like a bug to me.

Seems you are working around more severe issues also. If you have frequent restarts (that are not battery related) you should try and get at log and report the problem. I also hope you get paid really well and/or reimbursed for having to provide your employer with a usable Internet connection.

So the rest of the boot procedure is configured to be completely unattended in your case? Anyway, i assume you were aware you can put the tethering option on the top menu, which i’d dare say is pretty car friendly (with a well placed holder).

I agree to all the above said.
And I’d say the TopMenu item is the way to go.

But if you really ‘need’ it then take a look at what ubuntu connman manpage has to say.
And go editing


and try out setting

PersistentTetheringMode = true

Thank You for Your help. I tried PersistentTetheringMode = true. It didn’t change the behaviour however.

I just tried to fiddle with


to no avail (else breaking wireless and cellular data, so be sure to have a backup or know what you are doing).

Seems not doable…