Accessing SFOS MicroSD on computer

I want to access my Sailfish OS EXT4 formatted MicroSD card from a Linux laptop directly in order to transfer vast amounts of files that would take days over SSH or MTP. However after mounting the card I have no access to to it. What is the best way to handle this?

I am on fedora 38 and i just connect my phone via usb and i am ready to go…

1 Like

@247 Thís is what I do on Linux Mint and my life is full.

1 Like

Are you sure the bottleneck isn’t reading from SD card rather than those file transfer protocols? I can reach up to ~60 megabytes per second via SSH (or SFTP to be more precise) reading from the phones internal memory.

Edit: I realize my comment doesn’t really help anything. What are you using to mount/read your SD card, laptop or external reader? Have you tried any other reader?

2 Likes

That’s quite fast. I’m only getting about 5MB/s over SFTP both internal and external storage. I’m using the SD reader in this laptop. It mounts but I have no access to it, perhaps because it’s owned by a different user? I’m not very familiar with *nix file permissions.

Is your sdcard encrypted?

Why don’t you sftp to your phone, to sftp://defaultuser@yourPhonesIPaddress/run/media/defaultuser/yourSDcardNumber/ ?

The SD card is not encrypted. SFTP does work but it’s a bit slow

Yes that’s true. I can reach 1-2 MB/s when transfering files. I guess that’s the limit of X10’s CPU speed. For me it works reliable but takes it’s time.

Some time ago I had the same problem, tried to remove the SD card from phone and read out with a SD card reader. There I had the same issue as you now, but didn’t any further research. I guess there’s something special when SFOS formats a SD card.

I ended up mounting it on Windows using ext2fsd and it works flawlessly. Getting around 30-60MB/s in a fast PCIe MicroSD reader.

2 Likes

I’m still interested what the symptoms here are.

So you can mount the ext4 partition without errors? And then what happens if you e.g. ls /mount/point/sdcard?

Yeah it mounts fine without any issues.

ls /run/media/matias/SailfishOS/ yields
ls: cannot open directory '/run/media/matias/SailfishOS/': Permission denied

The answer is there “Permission denied”.
Mount it manually or transfer files as root.