4G not working for SIM1 slot after provider change

REPRODUCIBILITY (% or how often): always
REGRESSION: unknown.


For my XA2 Dual I just switched from Telefonica to Vodafone Germany. Telefonica Sim worked on 4G in Sim Slot 1 and 2. Vodafone Sim only works in 3G, but not in 4G in Sim Slot 1. In Sim Slot 2 however I am getting a 4G connection with the new sim.




Vodafone sim card works in 4G in both slots.


as stated in “Description”


This is somehow the condition described here:
However it makes me wonder that 4G works in Sim Slot 2, but not in Slot 1.

May it be that you have another SIM in slot 2 using 4G?

Then I remember something from JollaC (and I am not sure 100% with XA2, but think so) that there can only be one SIM in 4G the other falls back to 3G or less.

As on my device I have no problem with 4G in slot 1.
But I got the 4G availibility on this card only after having flashed Sailfish and used it for months. Directly via network from the provider, only a reboot was needed.

Thanks for the input. But slot 2 is empty when 4g in slot 1 fails. Several reboots with VF sim in slot 1 didn’t help either.

Is your 4G connection with slot 2 stable over at least a day or two?

I also have 4G problems. They are probably more similar to the 2018 bug report, but not exactly the same.

I’m also using Vodafone Germany.
I’m only using SIM slot 1 with my Xperia 10 as I need the SD card.
I have to restrict to 3G as otherwise the connection will be dropped sooner or later and I have to re-boot. (Completely dropped, not even 2G/3G any more.)
E.g. I always lost the connection when sitting for some time in a certain meeting room…
So, I would not be surprised if you would get a 4G connection with slot 1 at a different location.

Previously, with Xperia X and Jolla 1 I had such behaviour mainly when crossing borders and roaming took place.

It is not an issue of the network which is strong and stable at my location. My X10 has VF as well and has good reception. Nevertheless I had similar problems with the X10 at first and needed a complete reflash until the VF sim worked properly. I fear I have to go through the same process with the XA2 as well which is a shame and honestly not acceptable!
The thing with working in one of the two slots still makes me wonder…

Try a request via jolla.zendesk.com

where I have the bad feeling they will propose the same :frowning:

If you really have to go this way I would do a dd of mmcblk0p76, flash to Android, use SIM, reflash Sailfish, test the SIM in slot1. And then ‘import’ back the dumped sailfish partution. Maybe this works and you won’t have the need to set up all again.