[4.6.0.11] [Xperia 10 III] No mobile connectivity after reboot

REPRODUCIBILITY: 100%
OS VERSION: 4.6.0.11
HARDWARE: Xperia 10 III
UI LANGUAGE: Italian
REGRESSION: Yes

PRECONDITIONS:

You are in Italy and are using an Iliad SIM with a 5G plan in slot 1 (did not try slot 2).

DESCRIPTION:

After reboot, even if connection to a mobile network is successful, IP connectivity does not work.
The same happens after resetting the network subsystem from Prefs → Utilities.
Loss of connectivity also observed in other not well specified conditions.
Activating and deactivating airplane mode usually brings connectivity back.
I am in Italy with the operator Iliad.

STEPS TO REPRODUCE:

  1. Reboot your phone, or reset the network subsystem from the Utilities menu in Prefs.

EXPECTED RESULT:

IP connectivity restores after a while.

ACTUAL RESULT:

IP connectivity does not work, unless airplane mode is selected and deselected. Sometimes also changing the network preference between “Prefer 5G” and “Prefer 4G” does the trick.
The issue occurred both rebooting with “Prefer 5G” and “Prefer 4G” selected.

3 Likes

Can you please update your bug report and under the section “Preconditions” write:

  • Use Illiad

thanks in advance

Thank you for reporting. I filed an internal bug on this.
Getting some logs might help:

1 Like

I had similar problem after updated to 4.6. Elisa FI 4G. IPv6 worked fine but IPv4 did not. Network restart from utilities did not help but disabling mobile net and enabling worked. Defaut GW changed from ns.sci.fi to decker.sci.fi. Installed ofono logger and saved instructions to pdf if problem occurs again.

I think I’m seeing this at Elisa EE with 5G enabled. Phone seems to be switching between 5G/4G and either 5G stalls connectivity, or it’s the switching.

5G screenshot for proof. I’ll hopefully get to ofono log collection later.

I will send the report soon.

I had this issue too but it is not new to 4.6, I have had it after normal reboots on 4.5 too, having to switch to “Prefer 3G” and back to “Prefer 4G”, and fiddle around with Flight mode, atleast for USB-tethered data connectivity.

Please find the log here:

Some comments:
I started in 3G, reset the network subsystem from Utilities, the connection went off and did not resume after acquiring 3G again, turned on airplane mode, turned it off again, then connection came back (connected to 4G IIRC).

I guess the four lines containing “Unexpected data call status 2034” are the key to this issue.

After quick test, similar observations here on Elisa FI network.
Based on network indicator it looks like phone goes back and forth between 4G/5G.

It could do that if the 5G network is barely available. My Telia FI does the same, but there is no problem with the Internet connection. If it cannot work over 5G then it works over 4G. How is it in your case?

Yes I’d assume the same, but data transfers just stall. Been on Prefer 4G since reporting, and everything’s been working fine there. Still haven’t gotten to logging 5G.

The same issue occurred yesterday and today after crossing a section of road with no network available. ofono log was reporting the message “Unexpected data call status 2034”. Once again the airplane mode trick restored connectivity once the network was available again.

I had the same issue for more or less two-three weeks and switching airplane mode on and off solved it. Thanks @jameson for the workaround.

Xperia 10iii, 4.5.0.25, UI language French. I am not in Italy.

More testing done. Seems that connectivity is there and network indicator switches to 5G when more data is used. Then when UE falls back to idle, it switches back to 4G.
Don’t know how Jolla has implemented a network indicator for 5G but for example Nokia X20 shows 5G (NSA) in idle as well at the same location.

I restarted phone today due sound issue and after restart IPv4 connectivity was lost again. Toggling mobile data off/on fixed IPv4 connectivity issue. Collected ofono logs. https://www.puuppa.org/~teve/ofono.tar.gz

I noticed that my phone drops to 4G when it’s idle - meaning no or little data is transmitted. When I start e.g. browsing, it jumps to 5G. I guess that’s a power management function.

I am currently in Germany for the first time with my Xperia 10 III, Iliad SIM, and I cannot for the sake of goodness get a data connection on the roaming operator O2. Same ofono error, unexpected data call status 2034. I have to use my Android backup as a hotspot.

1 Like