[] [XA2] No mobile connection after upgrade



When the sim-card is inserted the boot-up process is not completed. Lipstick process consumes up to 100% of CPU. Only available and responsive is the top-menu. Take out the sim-card and the phone boots without issue.


Sim-card inserted in the sim slot


  1. Upgrade 4.5.x →
  2. Reboot XA2
  3. Network connections is not available
  4. Reboot XA2
  5. GUI is not starting, loading circle is displayed. Phone is not connecting to provider. WLAN is connected without issue.


Complete boot and connection to my mobile provider and if that is not possible for whatever reason, get me to the main screen.


Loading circle on the main screen. Only top-menu is available and responding. Camera from bottom-menu is not working either.

Storeman, F-droid, Aurora Store, Chum GUI



With Sim-card inserted:
Loading spinner

Mobile data/ location not available

Without Sim-Card inserted:

1 Like

Do you happen to have SIM PIN enabled? This is the first thing I think of when comparing to my perfect experience on XA2 — I have the PIN disabled.

Faced similar issue during upgrade. But multiple restarts finally brought back the mobile connectivity.

Thank you for reporting. An internal bug was filed on this.

Please check Obikawa’s question. It would be good to hear your answer.

I think it is worth to say my XA2 (for 2 SIM cards) is working fine after the smooth update. Also a second reboot after the update this time was not needed. Thx for this good work.

Differences to the OP phone: SIM 1 card inserted and pin activated, no SIM 2, no extension as listed in the start post and - of course - no android emulator.

1 Like

I don’t have a SIM pin set. Only pin in boot process is the one for encryption. <= 4.5.x no issue with the same sim-card.

Any recollection of how many restarts you tried?

One more idea: I have the dual sim variant of XA2. What about you?

Single sim version for me.

Thank you. This is an informative difference from the working build of XA2.
Hopefully the developers will be able to work out the true source of the problem with this information.

Well lo and behold. Tried it a third time today and it now boots correctly with the sim-card inserted and connects to the mobile data provider.

3 times to be precise after upgrade. First time no change.
Second time sim card was shown in top menu but not visible in settings( sim cards screen was empty). Third time booted up with network and data connectivity.

1 Like

FWIW - On my 10ii it took a while (at least a minute or more) but it reconnected to the network without reboots.

There may be an issue with slow network reinitialization based on the amount of reports.

1 Like

Adding to this, sometimes during restart with sim inserted hangs at loading screen with top menu being accessible. Restarting without sim doesn’t result in this.

I have an observation for this issue. The SIM initialization seems to be a problem. I get a message that the phone needs to restart to initialize the SIM card. When I press OK and don’t restart immediately it sometimes connects to a network successfully. In case it does not connect, it takes easily 10 boot cycles to get to the main screen. In some boot cycles I end up on the main screen, without the mobile connection active. Other boot cycles are the same as the screenshots I added before. When I have the loading spinner shown nothing appears to happen. The amount of time I give the phone to connect, does not influence the behavior.

  • Why would the phone want to initialize the SIM card when providers (during roaming) changes?
  • The boot cycle seems to be tide to initializing the SIM card (expected), but it is not clear why this is no consistently happening.
  • Once the handshake with the provider is successful all is fine.
  • This routine happens when restarting the phone, so I leave it on.
  • This routine happens after taking the phone out of airplane mode.
  • The amount of boot cycles needed to get connected once again to the network is not consistent. (Boot cycles needed 3-15).
  • As a side note a Pixel6 phone (running GrapheneOS) with the same SIM and trying to connect to the same roaming network needs quite some time to connect to the network as well. Non roaming network connection set-up with the Pixel6 is normal.