[] [XA2] [Austria] 3G Connection unreliable after update



After updating from to the 3G connection on my XA2 became unreliable.
After a reboot it works for a few minutes and then stops working.
That means i can neither call nor recieve call and the internet connection is not working as well.
After a reboot it works again for a few minutes.

Using the “restart network” option from the helper tools does not help, only a complete reboot.

Service provider is Bob (A1).


Having set 3G as prefered network.


  1. Start the phone
  2. Wait


Beeing able to call someone, or recieve a call.

When trying to call someone, there is no tone to indicate that it is ringing, the call is aborted automatically after a minute or so.


A friend coming over several times and telling me: “Your phone is not working, i tried to reach you via calling, sms and whatsapp”.




Switching to 4G as preferred network does fix the problem.
Having 3G as fallback would be nice.

As this is my first bug report, what should i do differently?
What was good?
I tried to explain the problem as good as i can, but there surely is lots of headspace for improvement.


Maybe it relies to the removal of the 3G network that’s going on now, and you had bad luck that a 3G base station was removed at the same time you updated SFOS.

Did you test with another phone on 3G, if something has changed?
What does the signal strength display say? Is it very weak? Any changes in the last days/weeks corresponding with this malfunction?

Maybe related: A1 turned 3G off on July 1.st in Slovenia. Maybe did they also in Austria?

1 Like

.21 touched nothing network related, so it would be very surprising if it had anything to do with it.

After your hint i just found a link that seems to confirm this: 3g/UMTS wird durch modernere Technologie ersetzt | A1.net
The write that they will turn off 3g completely in 2024.
But why would it work for a few minutes after every reboot then?

@Seven.of.nine: The signal strength seems to be the same as usual, about half to 3 quarters full - but even then no calls will go through.
Only sometimes signal strength symbol would show a complete loss of signal.

1 Like

IMO it is not related to the decommissioning of 3G by A1.
IMO it is related to the OS itself. I do not understand why the “advocates” are writing BS here.
To the “advocates” if you have no idea why saying something at all? It is often a virtue to keep your mouth shut.

Also why are you using 3G and not 4G?

Alternatively flash back to and wait until hopefully Jolla solves the problems introduced by 4.5.X.X releases. For your device 4.5 does not bring any benefit at all.
I am using Xperia 10 II with A1 (BOB) with “Automatic” network with After reading the couple of postings and complains about issues with 4.5, I did not upgrade.

It seems Jolla fixes one and breaks two. I’ve been complaining about this earlier as well. I don’t know what can be done.
May be you could try debugging and providing more information, so that someone can look into what is happening on your XA2.

That i was still using 3G basically goes back to my XperiaX, with which i started using Sailfish.
On that device it was the other way around, the 4G connection wasnt stable, and 3G seemed to use less battery, so i got used to setting 3G as my preferred network, even on the XA2.

If you mean me; @ me directly - and bring some facts.

Opinions don’t count.

And i will remind you to criticize ideas, not people.

Had the post been about 4.4 to 4.5, there might well have been merit to what you say… but it isn’t:

Don’t spread FUD.
The minor bugfix release that is .21 touched no networking at all, let alone cellular.


I don’t spread anything, it is merely an observation.
On and prior i did not have this problem, after the update to .21 i had.
Did i state any technical assumption about the how and why of the problem?

It is fine by me that .21 touched no networking at all, but that does not change the observation.
Yes, it may be that the observation may be based on coincidence, but how should i know beforehand?

1 Like

Have you contacted your network provider? Maybe the problem is on their side?

You did nothing wrong. It was a reply to deloptes.


@attah I didn’t mean you, but now I do. I have no idea, why you pick me to relief your frustration. I would suggest you visit a doctor.

Also who are you to tell me what to say, how to think and what to do. Again, leave me in peace and seek help somewhere else. I do not like one picking on me for no reason. You have no authority. And please note that I am writing harsh, because you are attacking me personally again, for no reason.

I live in Austria. I worked with few telecoms. I know what I am talking about.
The 4.5 is not stable enough - my observation.

I also suggested that @wakey tries 4G. I can confirm that works (almost) fine with 4G. But the XA2 had some other issues, compared to the 10II.

Live in peace and please avoid writing to me

1 Like

I learned the hard way that there are some people around us who just don’t have the capacity for self-reflection or compassion. Some of them at least try to better interact with others despite their limitation. Unfortunately not all.
I admit that sometimes it’s not easy to not judge. There’s this a bit cruel ‘between the lines’ joke to remind us:

“I’m driving on high speed separate lanes for opposite directions road to the RandomPlace minding my own business trying very hard to ignore all those stupid people. To make that a bit easier I turn the radio on and catch some nice music. Ahhh, better now! An then they interrupt my nice music with a traffic warning. It says: “Warning on the RandomPlace road. One driver drives in the opposite direction.” Darn, even the radio people are stupid. They all drive in the opposite direction.”

Please respect others the same as you respect yourself.
Don’t assume first that people are trying to insult you.

For our whatever issue we need your knowledge and experience here not finger pointing.