[4.5.0.21] Low Audio in WhatsApp Video Calls (regression)

REPRODUCIBILITY: 100%
OS VERSION: 4.5.0.21
HARDWARE: Xperia XA2 Dual Sim
UI LANGUAGE: English
REGRESSION: Yes

DESCRIPTION:

WhatsApp video call audio is very quiet and not using loudspeaker, even when volume is turned up to the maximum. It seems to only be using the earpiece, and there’s no option in the app to switch to loudspeaker, since loudspeaker is the default for WhatsApp video calls. This issue was present a few years ago after a previous Sailfish update, but was fixed with a subsequent update.

Loudspeaker option works for standard phone calls as well as WhatsApp voice-only calls.

This is occurring with the latest update of Sailfish. I think it was also happening after the previous update, but before that WhatsApp video call audio worked as expected.

PRECONDITIONS:

WhatsApp installed.

STEPS TO REPRODUCE:

Video call any contact in WhatsApp.

EXPECTED RESULT:

Clear audio from the recipient.

ACTUAL RESULT:

Audio is very low and seems to only come from the earpiece instead of loudspeaker. There is no option to switch to the loudspeaker in video calls - it should be loudspeaker by default. This means the phone has to be held to my ear to hear the other caller, defeating the purpose of video calling. The other caller has no issue hearing me.

MODIFICATIONS:

None.

ADDITIONAL INFORMATION:

3 Likes

Hi.
I’ve noticed the same issue on my 10 III a few months ago.
If I remember correctly, the solution was to click twice on the loudspeaker (turn off and on again) and that did the trick.

1 Like

Thanks for that, but I’m not sure what you mean by the loudspeaker - there isn’t a loudspeaker option for video calls, only for voice calls (and that works as expected). Video calls should only be on loudspeaker, so they don’t have the option to switch. I tried every other option too (mute, swap camera etc.) just in case, but no joy.

I did try a voice call, switching it to loudspeaker (also tried switching that off and on again) and then making a video call, but that didn’t resolve it.

You are right, it must have been a different combination like the one you described from call to video call maybe.
Because I’m 100% sure that I had a couple of proper sounding video calls, but that was a few months back.
I’ll check again probably in the next couple of days and see what worked in my case.

1 Like

I’ll raise this one as well.

1 Like

Cool… I should also point out that it hasn’t been fixed in the recent 4.5.0.24 update.

1 Like