@ Volla/GS290 Patchmanager - No Center Clock has no effect

On the Volla Phone, since a time, the patch ‘no center clock’ doesn’t work any more. It did work in earlier times. It’s possible to install the patch using patchmanager, to switch on or off in patchmanager (it asks for ‘some services must be restared’ but doesn’t tell which). So I did restart the GUI (‘Startbildschirm’) with SF utilities and also restarted the device completely but it has no effect.

This is a regression, patch worked in earlier times.

Does anybody know / is there an option to tweak some config file to move the clock away from the center?

In my limited experience of playing with the clock/time found in


there always seemed to be an overlap with other icons depending on what your device is doing.

Perhaps it can be shifted down rather than left or right, but then that may look a bit crap but won’t interfere with other icons when present…

Also, when you find the bit of code that controls/ mplaces the clock, you can compare patch contents, by doing so, you may be able to recreate the patch with the new code.

Below is the line of code which presumably is positioning the clock…good luck!

        Component {
            id: timeText
            ClockItem {
                id: clock

                width: Math.min(implicitWidth, centralArea.width)
                updatesEnabled: recentlyOnDisplay
                color: statusArea.color
                font { pixelSize: Theme.fontSizeMedium; family: Theme.fontFamilyHeading }

                Connections {
                    target: Lipstick.compositor
                    onDisplayAboutToBeOn: clock.forceUpdate()

1 Like

Works on my gs290

version 0.0.1 compatible up to .58
so currently red as incompatible

convert patches to 64 is enabled …

1 Like

Patchmanager catalogue shows me that it is compatible up to, but in the list only my version number is shown in white letters while all other versions from up to are shown in the highliting colour of my ambience! Has this a special meaning? is it NOT compatible?

My Patchmanager settings are:
Show notification on success: ON
Activate all enabled patches on startup: ON
Show menu ‘switch off all patches and deactivate them’: ON
Version check: no check
Mode for patch developer: OFF
Convert patches from 32 to 64 bit: ON

I choosed reinstall from patchmanager options.
I rebooted GUI with SF utilities (no effect)
I executed in CLI ‘systemctl --user restart lipstick’ (no effect)

last but not least: WHAT services should be rebooted?? (even a full reboot didn’t bring it to work…)

Thank you @Edz for this hint, so I can play a little with it. Can it be that the block before:

            Loader {
                // If possible position this item centrally within the iconBar
                x: Math.max((iconBar.width - width)/2 - parent.x, 0)
                y: (parent.height - height)/2
                sourceComponent: lockscreenMode ? lockIcon : timeText

has a chance to move the clock to the right away from the pixel range that doesn’t exist on notched devices?

This I have on 290, and GS5,

            Loader {
                // If possible position this item centrally within the iconBar
                //x: Math.max((iconBar.width - width)/2 - parent.x, 0)
                x: (parent.width - width)/2 + width + (width /2)
                y: (parent.height - height)/2

EDIT, don’t forget to make a backup first, just in case you make an error!

1 Like

I believe i did install.it few sfos versions before and did not update the patch. as it seems it s meta was updated to support .72 too

if i visit the patch i can re insrall it

Why isn’t this done in an update with Integrated with the clock?

I had the patch installed on Volla / and it worked. Then I reflashed the Volla few weeks ago and reinstalled the patch and now it didn’t want to work any more. I have no idea why.

After doing this tweak and restarting the GUI with SF Utilities, the time is now visible right of the notch when phone is unlocked with fingerprint.

In locked state (only after pressing the power button), a lock symbol is there and time is visible in big letters as always.

That’s exactly what I wanted, thank you very much @poetaster ! :smiley:

The reason is that they changed the Structure of StatusArea. I had a modified patch of my own and that killed lipstick. So, the patch needs to be updated …

1 Like

You’re very welcome! I should publish my patch since it also shows some other stuff up in the status area… but, but …

1 Like

I found that what they mostly did is moving from org.nemomobile.foo to Nemo.Foo imports.

Patches which do something at the top of the file thus “break” (technically quite unnecessarily) in that they don’t apply any more.

1 Like

Hmmm. I had some additional foo and just noticed my ‘old’ patch on the phone contained:

import Nemo.Time 1.0
import org.nemomobile.devicelock 1.0
import org.nemomobile.lipstick 0.1
import org.nemomobile.time 1.0

Which looks a bit redundant. What was I thinking! I haven’t gotten to testing it yet, but it’s also no so important (I had done additional date display.)

I didn’t know there were problems with 4.4, it just worked for me. I did re-done the patch for 4.5 though…

1 Like