[][Xperia 10 II] New bugs after update to 4.4

Hi all!

The last update introduce more bugs than features for me. I did not check if all bugs I see have already been reported but here is my list:

  • Sometimes I cannot make a call phone app is not responding to entering a number or clicking on a contact [no bug report found]
  • Clicking on an email or missed call does not open the mail program or the phone app [Bug]
  • Emails are not deleted on server [Bug]
  • Send emails are returned because some invalid characters were inserted (see image) [bug]
  • Cannot read email because a part of the mail is missing (see image) [not sure if that is the same bug]
  • Still loosing my network connection after a call [Bug]
  • Opening a link from a different app than the browser opens the browser and gives me the new page dialog. Link is opened in the background. [Bug]

I really have a hard time to understand how it is possible that with every release since 4.1 you manage to break more stuff in stead fixing things.

Since you didn’t bother filling in the bug report template, and (by your own admission) didn’t check for duplicates, nor could keep to a single issue, i took the liberty of moving your thread to General.

Took some time to look for bug reports. Looks like three issues have not been reported, yet. But I am done for today. Maybe I file a report later.

Are you sure the SFOS mail app is inserting invalid characters into the subject?
Can you show us the full error message (last lines in your screenshot), and of course copy-paste the troublesome subject line?

I’m currently not home and have limited access to the internet.

I tried two times to respond to an email I received and it came back twice from all recipients. They all had accounts with united (gmx and web.de). I did not check if it’s connected to united and if new mails are also effected.
The only thing I tried is to delete the last lines of the received email. Came back with the same error.

Responding from my laptop worked. Same account.

I have the same bug with the Email client.

Your screenshot says that the Subject contains invalid characters, which is why the mail was rejected.
It would be nice to see the complete error message.
And to know what invalid characters the subject might contain. Better use desktop mail for that, not your phone (easier to copy-paste).

FWIW, I’ve had troubles with GMX being way too trigger-happy wrt what they think is spam. Unrelated to SFOS.

HI @ohnonot,

I need to do a better job in reading stuff.

The error message had the original message attached. The subject startet with:

Re: Aw:�Re: �Re:

If I look at the source code of the email it looks like this:

Subject: Re: Aw: Re: Re:

There was a non breaking space entered. The first one seems to come from an Android app:

Diese Nachricht wurde von meinem Android Mobiltelefon mit WEB.DE Mail gesendet.

The second one must have come from the Jolla mail client. Interesting that Web.de rejects its own subject lines… Or does the Mail client change the non breaking space to a different one? There a plenty of different none braking spaces on unicode.

I will try to put this in a bug report when I have more time.

Please test this on your other devices (desktop computer etc.), try to rule out the SailfishOS device.