[ EA] Music over Bluetooth does not work anymore

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (XA2, X10, X10 II, …): X10 II
REGRESSION: (compared to previous public release: Yes, No, ?): Yes


While brought back the ability for me to use my Bluetooth headset and Bluetooth car audio system to make calls, it has broken the ability to stream audio to BT devices (tested with my Bose Soundsport headset, Bose Soundlink Micro, and BT speaker in my car.



  1. switch the headset or speaker on
  2. check that SFOS has successfully connected to it
  3. launch music (e.g. with stock music player, gPodder or Spotify AD)


Music plays on the BT headset/speaker


No sound is played, although the music is played (I can see the time counter moving)


(Please ALWAYS attach relevant data such as logs, screenshots, etc…)


Today I experienced something similar. No audio over Bluetooth to/from the car handsfree. Yesterday it worked. Rebooting the phone solved the problem. Interestingly, even switching to the phone speaker no audio was reproduced, and from the other side of the call my audio was not received either.

1 Like

I encoutered this twice. Reboot fixed it every time.

i tried it already, with no luck.

Stupid reflection, but is volume up on both side?

it is :slight_smile: i had checked already of course :wink:

OK, I made some progress:

  • I managed to have it working back, but BT audio only works when the headset is only connected to my X10 ii.
  • if the BT headset connects to say my laptop, the sounds disappears
  • as soon as i turn BT off on my laptop, it works again

These are Bose Soundsport headsets which can connect to several devices at the same time.

I should add that it used to work with SFOS <= 4.3

Today I got a strange behaviour with BT, but I’m not sure it’s the same bug as you described. Anyway, it’s always worth to test and if it’s really not related I’ll create a bug report.

My Xperia 10 II was connected to my home Wi-Fi and a headset was paired with my phone. Music was playing and once I left my home, music stopped. Visually, there were still a “connexion” but I was unable to hear music on my headset. Usually, I turn off Bluetooth on both side and pair again.

So my question, can Wi-Fi have an influence? If yes, is it possible that when losing the connection it creates some problem?

I don’t think WiFi is causing that - see next comment.

Confirmed - the issue appears when the BT device (applies to both my Bose headset, loudspeaker, as well as my car BT audio) are connected to another BT device, e.g. my wife’s iPhone.

If I turn off my wife’s iPhone Bluetooth, and reconnect SFOS to the BT device, then I have both audio and calls working just fine.

At least I know how to fix this, but again this used to work fine before :slight_smile:

Thanks to everyone involved for posting the bug, and also for finding the reason. I’ve tagged this bug as “fixed”, as I think there’s nothing further to do for it. Please say otherwise.

I’m not entirely sure David - it used to work before 4.4, so my feeling is that something got introduced in 4.4 that makes it behave differently.
The aforementioned solution is just a workaround IMO.

Thanks for your prompt reply Nico. In that case I think it might be sensible to create a new bug for the issue as it stands now (or maybe make edits to the original bug above)?

Currently there’s some key info missing from the report about the affected devices having multiple active connections (missing for understandable reasons, but if I transfer the report over as it is now, I think it will give an incomplete picture).

Would you mind creating a new report, or making amendments to this one?

sure, I’ll amend this one.

1 Like

The workaround I currently use is:
Connecting to my car hands-free… no sound… Starting a phone call, ending the call… sound works over BT.