4.4.0.58 Audio subsystem does not reset when USB headset unplugged; XA2+

REPRODUCIBILITY (% or how often): 100% (3 out of 3 tries)
BUILD ID = OS VERSION (Settings > About product): 4.4.0.58
HARDWARE (XA2, X10, X10 II, …): XA2 Plus
UI LANGUAGE: English
REGRESSION: (compared to previous public release: Yes, No, ?): I don’t know

DESCRIPTION:

Today I received a USB-C headset with microphone primarily for use on web video calls. Out of interest I plugged it into my phone and it worked perfectly for both input and output. However, after unplugging the headset, audio is not restored to the default internal speaker.

PRECONDITIONS:

None.

STEPS TO REPRODUCE:

  1. Plug a class compliant USB-C audio device into the phone’s port. I’ve tried two separate devices.
  2. Confirm audio (phone calls, replayed music) works correctly with the external device.
  3. Unplug the USB-C audio device.

EXPECTED RESULT:

Audio should be automatically routed to the internal speaker as previously.

ACTUAL RESULT:

The phone does not produce any audio. The phone does not audibly ring when calls come in, and no ringing tone is heard when making outgoing calls (I hung up before anyone answered). Playing audio from the media player app restored audio to the speaker after a few seconds, but incoming and outgoing phone audio was not restored after this step.

ADDITIONAL INFORMATION:

I’ve tested this with both the following devices:

  1. Microsoft Modern USB-C headset model 2026
  2. Samson G-Track Pro USB-C microphone with built-in headphone socket

I’m happy to provide any additional information that is useful. The important thing is to be aware that this happens. There are times when I will still choose to use one of these devices, knowing that I will have to reboot the phone when the call ends. Not knowing that, I missed an call that was important to me this afternoon.