[4.3.0] [fix] Whatsapp problem with pictures

REPRODUCIBILITY All the time:
BUILD ID = OS VERSION (Settings > About product):
HARDWARE XA2
UI LANGUAGE: English
REGRESSION: No (As far as I know)

DESCRIPTION:

Whatsapp (I think is android in general, but I only have whatsapp android) is unable to download images or upload images. When I click on the image, it says “download was unable to complete. Pleas try again later”

PRECONDITIONS:

STEPS TO REPRODUCE:

  1. Open whatsapp
  2. click on some image/picture that somebody sent to you

== upload ==

  1. Open Whatsapp
  2. Send an image from the galery

EXPECTED RESULT:

ACTUAL RESULT:

It should be able to download the images and upload the images

ADDITIONAL INFORMATION:

It was working since I updated last weekend the version to 4.3.0. When I tried to upload a picture, I’ve got the feeling the problem was that it was not able to access the image.

Do backups fail, too? I have two WhatsApp directories, both created July 13th, 2021 (probably when I switched from Jolla Phone to XA2):
/home/nemo/android_storage/WhatsApp
and
/home/nemo/android_storage/Android/media/com.whatsapp/WhatsApp (last written Nov 4th)

After the 4.3 update WhatsApp started using the former, which was nemo:nemo and 755.

What worked for me was

  1. chown -R nemo:media_rw /home/nemo/android_storage/WhatsApp
  2. chmod -R 775 /home/nemo/android_storage/WhatsApp
    (change to defaultuser if needed or use ~/android_storage…)
1 Like

I discover that I don’t have backups working since 5 june.

I don’t have nemo user, my mobile was a clean instalation of an xa2 (since 4.1 I think)

The only thing, is that I’ve got a memory card.

I found two folders with whatsapp:
1- ~/android_storage/Whatsapp
2- ~/android_storagge/Android/media/com.whatsapp/Whatsapp

I will try to remove the sd card and see what happens later.

Thanks!

Fixed, changging the group of te first folder (as you commented)

Thanks!

That’s wonderful thank you Ahtisilli and jsingla! I got my new Xperia 10 II working with Sailfish 4.3, successfully restored WhatsApp from the Xperia X, and no pics downloaded – which seemed odd since there’s masses of space on the new phone.
I ran
chown -R defaultuser:media_rw /home/defaultuser/android_storage/WhatsApp
chmod -R 775 /home/defaultuser/android_storage/WhatsApp
and now WhatsApp backups work, and pics download successfully :slight_smile:

Thanks @Ahtisilli !

I had the same problem with my Xperia 10 II after Sailfish OS update to 4.3.0.12 Suomenlinna.

Your fix worked for me too. Like @jsingla my last WhatsApp backup was from September, so I’m quite relieved that my WhatsApp media files started working again.

I’ll pretty sure I’ll remember now to also backup WhatsApp before next SailfishOS update. :sweat_smile:

Same here on my Xperia XA2: The Whatsapp folder changed after the upgrade to SFOS 4.3.0 and all my “old” data is not accessible from the app anymore…