[4.3.0] Camera & Torch not working

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (XA2, X10, X10 II, …): XA2 H113
REGRESSION: (compared to previous public release: Yes, No, ?): Did a factory reset and installed updates till; somewhere between version 3 and version 4 it was working fine - I didn’t test it in all versions.


jolla-camera crashes on startup, I suspect the torch is not working for the same reason.


Have Jolla Camera installed on Sailfish OS


  1. Start Camera application


Camera app loads & works fine


Camera app loads & crashes


Root privs required:

ssu ar adaptation-common https://releases.jolla.com/releases/
ssu ur
zypper ref
zypper dup

Note 1:
You may need to run first, if getting error messages on ssu ar:

rm -f /var/cache/ssu/features.ini
ssu ur

Note 2:
If you don’t have zypper installed (root privs required):

pkcon install zypper


Opening jolla-camera from terminal gets me:

[nemo@XperiaXA2 ~]$ jolla-camera
[D] unknown:0 - Using Wayland-EGL
jolla-camera: /usr/share/droidmedia/hybris.c:53: __resolve_sym: Assertion `ptr != NULL’ failed.
Aborted (core dumped)
[nemo@XperiaXA2 ~]$

What I also tried(as described here: Main camera does not start - #31 by peterleinchen):

[nemo@XperiaXA2 ~]$ devel-su; kill -9 $(ps aux | grep .android.hardware.camera. | grep -v grep | tr -s ’ ’ | cut -f2 -
d’ ‘) || kill -9 $(ps aux | grep .android.hardware.camera. | grep -v grep | tr -s ’ ’ | cut -f3 -d’ '); killall
-r .camera.; echo done;
bash: invalid number ‘camerase’
bash: invalid number ‘{provider@2.4-se}’
killall: bad signal name ‘r’
[nemo@XperiaXA2 ~]#

but no result.


Hi, did you have advanced camera installed?
previously I hade the same problem as you, I uninstall advanced camera and solve it.

Now I don’t have any problem with torch and camera on XA2 plus with 4.3

Please take a look to this bug report, it is exactly the same:

And for a quick workaround (definitely not a solution, which should be given by @Jolla or at least reacted to) please look here:

I didn’t have advanced camera installed. I don’t even know what that is; is it a sailfish native app or an android app?

Thank you very much, the workaround solved my problem!
I will update the bug report with the workaround.

And I confirm that advanced-camera does not have anything to do with this mismanagement.

Advanced-camera is a very nice enhanced native camera, available from official Jolla store as well as from openrepos.

It’s a salfish app, Who provides more settings for the came

On my two phones (Xperia 10) the same. Both cameras not working with Jolla Camera and Advanced Camera. Torch is also not working.

But both cameras are working fine with Android app “Delta Chat”.

edit: on my wifes phone (Xperia 10), Jolla camera is working fine (both cams), Advanced Camera started OK with main cam, but selfie cam not working. app crashed after few attempts to switch back to main cam. Torch is working.

edit: See here, this solved problems with Jolla camera, torch and video playback. Thanks to @peterleinchen !

Please take a look here for solution by @Jolla

1 Like

Advanced Camera was a good working app, better than the native app.

I have the same problem. Both camera and torch not working in 4.3. There are so many problems with main features at the moment (e.g. when in browser and someone calls, the calling menue disappears). I am discouraged by it, so I hope that the Jolla team can restore this bug.

I have the same problem and followed your suggestion, but no, it didn’t work. The wheel of the camera app keeps turning.

Yes, my suggestion worked for me… but not for my girl friend. It seems I had a very particular problem

Can it be, that some library is missing in SFOS, that Advanced Camera needs, and that can be downloaded from OpenRepos or Chum?

I have the same issue on XA2 Plus with 4.3.

Does upgrading to 4.4 fix the problem ? Or the only solution is the workaround via the terminal ?