[4.3.0.12] Alarm fires at wrong time

REPRODUCIBILITY (% or how often): Always
BUILD ID = OS VERSION (Settings > About product): 4.3.0.12
HARDWARE (XA2, X10, X10 II, …): X10
UI LANGUAGE: Russian
REGRESSION: (compared to previous public release: Yes, No, ?): Yes

DESCRIPTION:

Something looks to be seriously messed with timezones in the Cock app. When I set an alarm, it fires 2 hours later than the time I’ve set for this alarm. This started happening after upgrading to 4.3.0.12.

PRECONDITIONS:

Sailfish OS upgraded to 4.3.0.12.
Two SIM cards from countries with timezones 2 hours apart (may be related, may be not).

STEPS TO REPRODUCE:

  1. Start Clock app.
  2. Click on an existing alarm in “Alarm” tab. For example, 11:00. A popup at the bottom shows correct time until the alarm.
  3. Wait until alarm files.

EXPECTED RESULT:

Alarm fires at the selected time. For example, at 11:00.

ACTUAL RESULT:

Alarm fires 2 hours later than expected. For example, at 13:00.

ADDITIONAL INFORMATION:

There are some reasons why I presume that this issue might be somehow related to timezones.

  1. When I create a new alarm (say, for 12:30), it’s shown in the Clock app as two hours earlier (like 10:30).
  2. When alarm fires (2 hours later than it should), the alarm screen shows both time 2 hours ago (when alarm was supposed to fire) in bold, as well as current time in dim below it.
  3. I’ve returned from Latvia to Ireland just few weeks ago, and alarm fires just like if it was set in Latvian timezone.
  4. I have Irish SIM card in slot 1 and Latvian SIM card in slot 2.

Edit 1:
Systemwide timezone looks correct, though. I have correct time on lock and home screen, as well in date command’s output in shell session (using Terminal app or logging in with ssh).

2 Likes

Hi, I was about to submit a similar bug and unfortunately hadn’t gotten around to it. I’m in Dublin and have an X with an American SIM and a 10 II with an Irish SIM. After the update, the time on both devices on the lock & home screens went from GMT to EET. However something in the system had kept the correct time, as when I saved a file in FileBrowser it had the correct GMT time next to the filename.

Issue persisted following a reboot of the phone.

On the 10 II now, have checked in Settings by deselecting the Automatic Update option and as soon as I tapped the switch off, the timezone did change to Helsinki. Changed this back to Dublin but still showing EET on the home screen. Reboot & still there. Thought it may have been some kind of reversion to factory default during the update but having seen your post, maybe also a glitch of some kind with the Dublin timezone setting?

I had an American SIM card alongside the Irish one in the 10 II previously but not at the time of the update. IIRC when setting up the phones and selecting timezones, there was something odd about the time displayed when choosing Dublin (may have been an hour off?) but that it displayed the correct time when moving on, so it wasn’t a problem (may just have been DST related also). Have not yet had a chance to do a reset and check this again however. Will go through same steps on the X soon to confirm same behavior and may also do a reset.

After the update, the time on both devices on the lock & home screens went from GMT to EET.

I have correct timezone on lock and home screen. And correct timezone in shell session (both in the Terminal app and when logging in using ssh. The only problem I’ve seen so far is with the alarm clock.

I’ve added this observation to the bug description.

I had this last night in Finland (thanks for confirming I didn’t dream it up) and wondered about this in SailfishOS Fan Club at Telegram.

Morning,

How do you troubleshoot SailfishOS waking you up at 4 am or so with an alarm saying 6.59 when you kind of are still sleeping? Has anyone had similar experience?

someone was suggesting that it sounds like a timezone stuff.

It does suspiciously sound like timezone, but if I was awake enough to establish the time properly, UTC offset to Finland doesn’t match, it would have been 4.59. Additionally DST ended in European Union about two weeks ago and SailfishOS followed that properly

Suomenlinna / Xperia 10 II
The alarm is on from Monday to Tuesday with message “Bonan matenon”. I have a lot of alarms, but the next one is three minutes later at 7.01 “3 tippaa o-korvaan” (identical one at 19.01) (I have ear infection (again) and trust my phones to remind me to treat it)and there is also one alarm at 8.01 “Lasipalatsi 10/4” reminding me to leave to work try-out practice (practically internship)
(fwiw 8.01 alarm works)

7.01 alarm didn’t work due to me powering off the phone at night when it woke me up at a weird hour and I woke up to iPhone and dedicated radio/wakeup-light/alarm clock.

Additional information I didn’t mention there: I always have airplane mode enabled at night and I manually stop Android support before going to sleep. The carrier is Elisa/Saunalahti (Finland) and plan is “latausliittymä” previously known as Norppa (mix of prepaid (you top up the contact) and postpaid which is valid for two years since the last charge). I use the phone in Finnish.

I didn’t touch my Telegram quotes more than adding italics to what I think may be relevant information.

Quick update–I reset my Xperia X by flashing v4.3 back onto it, however same issue arose. No errors when choosing the timezone in setup. First indication of the wrong time was when the demo shows the Clock app in one of the steps but then it’s also wrong on the home screen for me (2 hrs ahead).

Terminal shows correct time here as well and interestingly, when I change the time format to 24-hour in Settings it fixes the issue, then errs again should I change back to AM/PM. There’s no issue when switching to other cities in the same zone (e.g. London/Lisbon/Reykjavik)–correct time everywhere. I use the phone in US English.

Do you have two SIM cards? Have you been in a country that has its timezone 2 hours ahead of yours?

No just one SIM in each phone currently and have not been to a country in the EET zone.

Seemed to be related as any shift to EET could easily be down to that zone being system default, independent of where the phone’s been. Also because of the Irish timezone being the only one causing problems on my devices.