[4.2.0.21][Xperia XA2] No keyboard shown for any of the applications on device

REPRODUCIBILITY (% or how often): 100%
BUILD ID: 4.2.0.21
HARDWARE (Jolla1, Tablet, XA2,…): XA2
UI LANGUAGE: English US
REGRESSION: (compared to previous public release: Yes, No, ?): Yes. Keyboard worked fine before Verla.

DESCRIPTION:

None of the applications (native or android) show a useable keyboard.
Text input is not possible in any of the applications on this version.
The space for keyboard opens up (blue rectangle at the bottom of the screen) but no letters/digits are displayed.
Keyboard area can be swiped away.
Adding, removing Settings->Text input->Layouts did not help.
journalctl show only this line when keyboard ‘drawer’ opens:
Sep 17 20:52:25 Sailfish invoker[5476]: WARNING: requestActivate() called for QQuickView(0x4ebb10) which has Qt::WindowDoesNotAcceptFocus set.
Don’t know where to dig further.

Did not try to downgrade yet.

PRECONDITIONS:

STEPS TO REPRODUCE:

  1. Open an application (messaging application, browser)
  2. Tap on a text edit field.

EXPECTED RESULT:

Keyboard shows up and is usable.

ACTUAL RESULT:

Text input is not possible.

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

1 Like

I have seen this behaviour (no keyboard/numpad) maybe once and could fix it with a reboot.

Frequently (once a day) I get only the numpad on text input fields. Maybe this is related. Only workaround is to reboot the device. This has been introduced with 4.2.0.

My device is a XA2.

I experience also on Xperia 10 ii (SF 4.2.0.21) to get the numpad as the only tool when wanting to enter text. Moreover the numpad is not functioning. However, the problem doesn’t need a complete reboot to fix, it’s enough to restart the screen by Sailfish Utilities.

My impression is that this behaviour may be triggered from activating some of the community supplied apps in Jolla Store, apps that hasn’t been updated lately.

Got the keyboard back. Thanks for the hint about the apps.

A couple of versions ago I had added a language qml file. After upgrade it gets removed form usr/share/maliit/plugins/com/jolla/layouts. Previous version could work without it. Verla got confused.
Adding the language file back and restarting maliit-server worked.

Thank you for the hint to the Sailfish Utilities. I removed them some versions ago.

I can confirm that restarting the screen is enough to reenable the keyboard.

I had this bug now the first time after a couple of days. And I still have no idea which app might trigger this.