[4.2.0.21][Xperia X] First web page can only be in open mode, not in private mode

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): 4.2.0.21
HARDWARE (XA2, X10, X10 II, …): Xperia X
UI LANGUAGE: slovak
REGRESSION: (compared to previous public release: Yes, No, ?): No

DESCRIPTION:

When you launch the Sailfish browser, the start page / view is displayed. In this situation, it is not possible to choose private browsing and therefore the first web page can only be in open mode, not in private mode.
The browser does not remember private mode when turned off.

PRECONDITIONS:

Browser settings: Home page - default

STEPS TO REPRODUCE:

  1. Start Sailfish browser

EXPECTED RESULT:

Allow to switch to private mode on the start page at starting browser.
Remember the selected private mode even after turning off the browser

ACTUAL RESULT:

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

7 Likes

This is indeed very annoying and hasn’t been fixed with latest update 4.3 :disappointed:

1 Like

I totally agree, this is not how it should be.
As a quick and dirty workaround, I set http://about:blank as my homepage in the browser settings.
Each time the browser is started, a blank page is displayed and a new tab can be opened in private mode using the menu icon.
Unfortunately a bit awkward, but better than calling up a random website and then having to delete it again in the history.

But I would rather have the previous behaviour again: Exit in private mode = start in private mode.
Or even better, a settings switch: Start in private mode

3 Likes

I can confirm this on my Xperia X with 4.3.0.12.