[] Xperia 10 Plus with low charge in reboot loop

My phone was on a low charge and went into a reboot loop without me realizing and now it won’t charge at all, just constantly rebooting, showing the unlocked bootloader screen and then the Sony splash before blacking out and rebooting.

I’ve tried:

  • powering down (Power + Volume up for three seconds)
  • flashing hybris-recovery.img using fastboot
  • leaving it plugged in whilst in flash mode (Vol up whilst inserting usb) for over 30 minutes

but there’s no change and it just keeps rebooting upon cable insertion in the first two cases, and in the last it just reboots as soon as I execute the command.

Aside from removing the battery and charging externally (which is my last resort), is there any other tips I could try to get this thing charging and booting normally?

Have you tried holding volume down while the phone reboots?

Thanks, that’s interesting, it just reboots whist using a wall charger, but when connected to a PC, i get a red led (with a slight fluctuation), green led, blank (I’m assuming it’s like a quick reboot here) loop.

I’ll try holding it down for a while and see what happens.

afair the 3 seconds Vol-Up + Power is a reboot command. Try holding it for for 6-8 seconds (and, again only iirc, it should vibrate three times). Then it is a hard shutdown. After that try connecting charger.

Oh I tried that, and something off a Sony Help site saying hold them down for 2 minutes.

It feels like there’s some software that handles charging, but there’s not enough charge to load it. I remember with the N9 you could get into a low charge state, and had to keep inserting the cable to build up enough to charge normally, but I don’t think this device has that capability :frowning:

Oh and if that re-plugging did not help on N9 (mostly rescued me) we still had the flasher trick! :slight_smile:

But on those shiny Xperias no idea! :frowning:
I would have expected the fastboot connected device to charge?

No it doesn’t seem to take a charge just left in blue led (flash) or green led (vol down) mode. I tried waiting a while before flashing the recovery image, but it just went straight into the boot loop.

I’m going to try on a PC with USB 3 later, but I think I’m going to just buy a new battery and replace the thing while it’s open.

Before you buy a new battery, try a power supply of a laptop. I have seen this with Xperia X and a weak charger. With a decent charger it eventually broke out of the loop.

1 Like

Thanks for this tip, I recall it working for me too with my Xperia X. Sadly it doesn’t work with the 10 Plus, so now that I have a new battery and back (mine had broken in front of the fingerprint sensor) I’ll attempt to get it working tonight.