[] [XA2] ViewRanger doesn’t work anymore

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product):
BUILD FLAVOR (devel, testing, release): release
HARDWARE (Jolla1, Tablet, XA2,…): XA2
REGRESSION: (compared to previous public release: Yes, No, ?): Yes

ViewRanger is an Android app that shows topographic maps, connects to the GPS and records a track of the path.
It always worked with previous version, but after the update to 4.2 it has great problems.
It can still show the map and it looks like it works correctly if the GPS is not enabled.

If I start recording a track the app continuously polls the GPS to record my locations. After a time that usually is less than an hour the app hangs and it is not responsive any more. I noticed that if I have other Android apps opened those apps are not responsive too.
Native apps keep working so it looks like this is a problem with the Android support.
Sometimes the phone is responsive enough and I can restart the home screen: after the restart the app works until the next crash.
Other times the phone shows only a black screen and I need to turn it off.

The app usually hangs when I look at the screen or I pan the map. Before hanging panning looks much slower. Sometimes the app hangs when the phone is in my pocket so I lose a part of the track.
This is a big problem for me because ViewRanger is one of my more important apps and I really to have it working.

Thanks in advance for your help.



Install ViewRanger from ApkPure, start it and begin recording a track. The app hangs after some time.

1 Like

Well, I use Locus Map for topo maps in Android App support, and I have not noticed such a behaviour.
You can try OSM Scout as well, a native SFOS app, which can also be found in the native store. It has very nice maps, and can record (and also import gpx) tracks (check image)

The Android app that behaves like your discription for me is Sygic. It works fine for 10-15 minutes approximately, and then freezes and becomes unresponsive. When this happens, I minimize Sygic and reopen it, and continues to work for 10-15 more minutes.

Thank you for your answer.

I am using ViewRanger because it can show commercial maps of my region (western Alps) that are much better than the OSM ones. For this reason I would really like to be able to keep using it.

I downloaded OSM Scout some time ago but I was not able to find any documentation and I did not understand how to use it. Today I tried it again: I started a track recording but I was not able to see the track on the screen.
It’s a pity because the app looks promising, but I really cannot understand how to use it.

Some time ago an OS update was available: I updated but the problem was still there.
I realized that I was using Android apps for everything I did with the phone, so using SailfishOS was not very rational.
I used this OS since the Jolla1 days and I really like it, but unfortunately I kept having problems.
I need a phone where my apps can run in a reliable way, so some days ago I flashed Android in my XA2 and I must admit that I am surprised of how well everything is working.

I wish SailfishOS the best of lucks, but now I moved to Android and I don’t think that I will ever go back.