[] [XA2] Signal doesn't work anymore

REPRODUCIBILITY (100 % or how often):
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (XA2, X10, X10 II, …): XA2
REGRESSION: (compared to previous public release: Yes, No, ?): Yes


after the update Signal (Android App) doesn’t work anymore. It starts but no chat can be opened. So there is no response on any tapping on the screen besindes that it seems to restart after a while.
After an refresh installation and registering
Signal can’t sync contacts
when i enter the phone number signal doens’t respond on clicking start conversation with phonenumber xxxx…




  1. start Signal and try to use it


An usuable app.


App is not usuable at all.


(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

Have you tried to disable Wifi, stop and restart AlienDalvik?
It happens often to me, if I leave home the phone keeps on searching for my home wifi and does not connect to mobile broadband. I cannot say if AlienDalvik/Signal recovers just from disabling wifi or if it needs a restart.
Thanks god, no-one of my friends and family have found out yet, it’s quite embarrassing.

1 Like

i tried it now but it doesn’t work it doesn’t seems like just a connection problem the UI becomes unresponvsive

Inadvertent restarts of Signal can be caused by low memory conditions that affect AlienDalvik. Try closing a few of the other (native) apps that you normally run in parallel.

1 Like

this also happens on a fresh restarted device, with only signal running.
Does the Signal (Android App) works for others with
Maybe this is a problem i can solve with reflashing. But this isn’t the prefered way. :weary:

for me signal works fine.
Im running a XA2 Ultra with SFOS 4.2 Signal Version 5.22.7 (not the latest version)
Are you running the latest update? (5.23.8)

yes i have 5.23.8 so the last version i had it already before upgrading

On my Xperia X 4.2 with Signal version 5.23.8 I can not send photos or use the camera to take a picture.
But I can send as a file.

And can chat normally.

On my XA2+ Signal 5.23.7 runs without any major issues. (Camera also works). It’s just that my Signal can’t read / load images taken from internal camera, neither I can share images from WhatsApp to Signal. But this is another issue than yours.

this problem i had in before als well but after a while the pictures appears for me :thinking: you using microg or just AlienDalvik?

1 Like

Just plain AlienDalvik

For me, Signal works flawlessly: I can send and receive messages and attachments. I can even take pictures directly in the app. XA2 Dual SIM, Sailfish, Signal 5.23.8, microg installed.

strange :thinking: i don’t use microg in before going to it works like expected just that sometimes pictures done with the native camera needs a bit to apear in signal but all the rest works smooth.
It is possible to uninstall and reinstall AlienDalvik? before reflashing the complete phone?

It is possible to uninstall and reinstall the android compatibility from Jolla store without full factory reset. I’m not sure if this removes all android app data, but it might be a goid idea to uninstall all android apps before uninstalling alien dalvik.

mhm than i guess something is broken on my phone
when i go to the jolla store and go to my apps it just shows the filemanger to me :frowning:

Works perfectly on my XA2 with Verla. The only very small problem is that although I am notified about new Signal versions I have to install Signal manually from the website.

pkcon refresh?
Maybe that helps.

Thank you for you help i made a clean reflash and notice that eg the browser looks different it seems that the update was not complete and the app was on an older version which cause conflicts :frowning:

I have an other problem with Signal since the update to verla. I use Signal 5.24.6 (Webside-Release). I activated the pin-lock for signal.
problem is now: I open the app I get the “Signal is locked” Screen. After I tab on “tab to unlock” and type my pin, it returnes to the “signal is locked” screen.
Deactivating the android-Pin with aliendalvik-control is not possible because this side is broken. Is there an other way to delete the pin from Aliendalvik?