[4.2.0.19][Xperia 10II] No Internet connection on Mobile Data when leaving WiFi if `Data access point`: `Protocol` is set to `Dual` (default)

REPRODUCIBILITY (% or how often): Not sure yet. Experienced multiple times.
BUILD ID = OS VERSION (Settings > About product): 4.1.0.24
HARDWARE (XA2, Xperia 10…): 10II
UI LANGUAGE: German
REGRESSION: (compared to previous public release: Yes, No, ?): ?

DESCRIPTION:

Some websites and apps suddenly have no access anymore to most of the websites while recently visited websites (like the default search engine) seems to work fine in some cases. Most of the time e.g. the default search engine in the native browser still works, but not the others. Or Fernschreiber (telegram client with tdlib) can access the network, but other apps like Piepmatz can not connect to twitter.
A reboot does help. Restarting networks from “Hilfsprogramme” does not.

PRECONDITIONS:

After changing from WiFi to mobile date.
Telekom.de SIM
EDIT: Settings -> Mobile Network -> Data acces point: Protocol is set to Dual

STEPS TO REPRODUCE:

  1. Change from WiFi to Mobile Network
  2. Go to Browser and start to open websites

EXPECTED RESULT:

All websites work fine

ACTUAL RESULT:

Most internet applications does not work. Android and native apps are affected. Internet Sharing is also affected.

ADDITIONAL INFORMATION:

8 Likes

Seems like you only have an IPv6 connection, without IPv4 support.
Go to Settings -> Mobile Network -> Data acces point and check that Protocol is set to either Dual or IP.

1 Like

Thanks for the Idea. It is set to Dual, not IPv6. But next time I see the Error I’ll try to change it to IP and see if it changes something.

Ok, I tested it. After leaving the WiFi again I had the same Issue. I changed from “dual” to “IP” and restarted the network. Then it worked. Then I switched back to Dual. It still worked. Then I went back to the WiFi. Then again WiFi of → same Issue.

So: “Dual” to “IP” seems to be a workaround. But Seriously: I want IPv6. So I assume there is a Bug somewhere.

3 Likes

I’ve seen this, but pretty infrequently. So infrequently I wondered if I was imagining it, but still . . . I’ll mess around with the v4 vs v6 a bit and see if I notice any pattern.

1 Like

Update: With staying at the ip selection for the protocol i never had that Issue again yet. So the workaround seems to be somehow ok for the moment.
I’m willing to provide more logs or data that help to iron that out if someone tells me what they need!

I have the same problem!
The bug seems to be at routing table! When i check route, default route stays on ‘wlan’ even if wifi is disabled. So there is no correct route for IPv4, while all sites with IPv6 are working!
According to above suggestion: If I select “IP” with IPv4 only, then route is changed correctly to rmnet_data0.

Other issue: Why do I need to select SIM1 every time I enable mobile data. There is only one SIM, so no need to select anything. Does it behave same on your device?

1 Like

Where do you enable mobile data? I’ve never have seen a dialog asking to chose btw sim 1 or 2 when only operating one sim.

Some of the Sony Xperia 10 II are dual-sim, even if you only populate one slot, the second slot is still available and you need to choose which slot to use. I doubt the dialogue appears on a single SIM device.

Otherwise I can confirm the bug, trying the workaround now.

I can confirm this bug. If data access for mobile data is set to “IP” (done manually via the settings menue), I can reach both, https://www.heise.de/ and https://www.techstage.de/

When the the data access point is set to “dual” (the default mode), then I can only reach https://www.heise.de/ but not https://www.techstage.de/

Should this be tested for being fixed with the 4.2 Release, or isn’t a fix assumed for this bug?

The main issue with IPv4/IPv6/dual is not yet fixed on 4.2.0, unfortunately. Some related fixes are included.
Work in progress.

3 Likes

Ok. Thank for the Update on that Topic!

Anyone experienced this in wifi mode? I had this on my xperia xa2 after updating to 4.2.0.19 (verla), before no problems like that. It seems to happen especially when you have low signal strength, while the native apps have internet connection e.g. native browser loads pages, while chrome, etc. shows “no internet connection”.

I click Airplane mode on and off quickly and that fixes this for me.