[4.1.0] Android apps crash when DRM/Widevine is used

REGRESSION: yes; worked in 4.0 and earlier


Since 4.1.0, whenever I use an Android app which (tries to) use the platform’s Digital Restrictions Management (DRM), the app crashes. AFAIK, the Android DRM is Widevine, which is build in in Google Play Services, which of course I don’t have. The Netflix app, of which I use an ancient version (v4.15.1, version code 14947) because that one at least worked without requiring DRM, now simply crashes on start-up. Worse, Firefox also crashes whenever I encounter a page with DRM. That can be as little as some embedded soundcloud widget.


  • Android support installed


  1. Install Firefox
  2. Navigate to Kijk alles van NPO op NPO Start (Journal of Dutch public broadcasting)


Video doesn’t play, because of DRM not available (WHY does that require DRM?!), but otherwise no issues.


The browser tab (process) crashes.


Using Aurora store, from f-droid, you can install aforementioned version of Netflix from the play store, via “manual download” using code 14947. I you don’t even need an account, as it crashes on start even after a clean install.


I can confirm the behavior. The old Netflix app with the version number v4.15.1 worked without any problems until sailfish update 4.1. Now it crashes right after the start. Is there a way to fix the problem? Or is it foreseeable that the old or even newer Netflix versions will work with Sailfish? Or at least via the browser?

i am also experiencing this can someone please help us

I also am facing this issue ,particularly with netflix

Same problem, hope Jolla will fix it with the next update.

Guys this has been fixed with the 4.2 update

Hi, I have the same problem with the app “onleihe”, see divibib.com
You can lean digital audio books, which you can hear over the phone.

The problem exists for me already in in .72 it doesn’t, too.

See picture.

Can this be solved somehow?

The problem was that the process crashed, instead of showing the message. The lack of DRM (and thus this message) is not a SailfishOS problem. Contact the software vendor of the app about this, or obtain your media from alternative sources without DRM.

Thanks, I’ll use a android tablet for this instead.

If I’m understanding the thread properly, this turned out to be an issue with the Android apps concerned.

Given this, I’ve tagged it as “fixed” and will close the topic. However, if I’ve misunderstood, you think this is a mistake, or still want to add to the discussion, please send me a direct message and I will open it again.