[][Xperia XA2] Updating apps in jolla store and pkcon refresh not possible

After update the os version there where updates for the “android app store” and “document” available in jolla store. But updating them is not possible. I just get the message “Update not possible”.

I tried “pkcon refresh” on phone terminal and using SSH, but on both ways I get the error message: “‘SSL certificate problem: certificate has expired’”.

I think this problems are connected, but I’m not sure.

By the way: Installing new apps is possible.

Similarly upon my XA2 elicits:
Fatal error: Download (curl) error for ‘https://sailfish.openrepos.net/coderus/personal/main/repodata/repomd.xml’:
Error code: Curl error 60
Error message: SSL certificate problem: certificate has expired

1 Like

Like the error says, openrepos certificate has expired. While waiting for them to renew the certificate, you can try this to disable all openrepos repositories:

for i in `ssu lr |grep openrepos|cut -f 3 -d ' '`
ssu dr $i
1 Like

Do I have to reactivate the repos afterwords manually? Or is it possible automatically?

Do you think the “pkcon refresh” problem is connected to the problem updating apps? If not: Any suggestions to fix the problem updating apps?

@vige Thanks for your advice. I tried it and now I can run pkon refresh. But it would be interesting to know how to “automatically” reactivate the repos.

Also I got to “solve” the problem with the “android app store” (aptitude). I simply installed the Aurora Store from F-Droid.
I also tried to removing the “document” app and reinstalling it. But after installation I get the message that there is a new version available. This new version I still can’t install…

In theory the same commands should work, you should just change ssu dr to ssu er. Personally, i wouldn’t do it though. The openrepos repositories cause way too many issues because of conflicting packages, so I like to keep them all disabled myself, only enabling them when if I need them.

@vige Using ssu er instead of ssu dr works fine. :+1:

But still I can’t update the apps using the jolla store. How to update apps using console?

I found out that my upgrade via OTA was not finished not properly.

ssu re
gave back

I did the upgrade using:

ssu re
version --dup

Now all problems are solved for now. Thanks a lot!!

1 Like