[][] Calendar app not starting Koli

REPRODUCIBILITY (% or how often): 100
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (XA2, Xperia 10…): XA2
REGRESSION: (compared to previous public release: Yes, No, ?): Yes


Calendar app does not start.




  1. Click app icon
  2. See app starting
  3. App disappears


Calendar opens


Calendar does not open


Deinstall and re-install from Jolla store solves the problem, calendar entries remain

A good friend of mine just had the same problem. We had to uninstall jolla-calendar from the cli after a backup. Uninstalling from the gui did not work. After reinstalling the app from the Jolla Store everything worked perfectly again.

# pkcon search jolla-calendar

would be the first step. But please make sure to fully understand what you are doing before proceeding.

Related to this one?

about dyncal and dynclock?

Please note that we have the following issue with opening the Calendar app (from UI) on 4.0.1:

Calendar app does not open anymore if user cancels first permission query and tries to reopen the app.

  • Remedy: Restart phone, open Calendar, accept permissions.
  • Fixed to the next OS release.
1 Like

A problem here is that as the phone restarts after the update, it automatically opens all the apps that were previously opened. The request for permissions is not seen. I rebooted my phone and the problem persists. It is only when I killed all the open apps and opened them individually that the permissions request is seen. This applies to things like the email accounts too as although I had a notification that I had new mail, the app still said that I had no accounts.

Another problem with the Calendar app seen here is that it never stops ‘syncing’. The top bar is continually flashing even though several minutes have elapsed since I requested a ‘sync’. All my calendars are shown however. In case it makes a difference they’re all from a Nextcloud account.

If I go to the Accounts page in Settings and ask there for ‘Update Calendars’ I get an error ‘Server response could not be processed’. The Calendars entry is then greyed out. I’ll look at that after checking the FAQ related to the update.

1 Like

I agree on the assumption the error is caused by not showing permissions after reboot. This happened after upgrading to (from 3.4). The easiest solution was to uninstall the calendar and re-install it from Jolla store, then the permissions were asked and the app worked without any problems.

Update - problem still exists. Today Calendar app did not start again, needed to re.install it. No permissions were asked

I have the same problem. Do you found a workaround?

No, unfortunately not. I think we have to wait for next update…

My temp. solution is do not close the calendar app. This works for me. Yes not nice but its the own solution in the moment.

Problem still exists in Kvarken 4.1.0

Based on a comment in the jolla Store, I made following experience:
The problem seems to be linked to a patch, which shows the date of the day in the app-icon. I had removed it already, but the icon was still showing the day.
Then I uninstalled patchmanager and the Icon remains as original. The problem does not exist anymore, the app starts each time without problems.

After reboot, the icon displays the date again and the app does not start anymore.