[4.0.1.48] Phone unresponsive after update

Last night I have updated Sony Xperia XA2 Ultra dual sim to 4.0.1.48. Progress bar on update screen went all the way to completion a remained stucked od 100% the whole night. I tried to reboot the phone and after few cycles of showing white screen with sony logo it finally booted SailfishOS. I have entered PIN code and all was working fine. I have received some calls, sent some SMS, read e-mails, done some web browsing.

However after pulling the phone from my pocket later, I have discovered that it is not responding. Screen is black, buttons do not work. Holding power button does nothing. Pluging the phone to charger / USB cable does nothing, even the small LED indicator does not light up.

Tried VolumeDown + Power with USB cable plugged in and the device shows up as:

Bus 001 Device 067: ID 0fce:ade3 Sony Ericsson Mobile Communications AB QUSB__BULK

I googled it, and it may seem the phone is bricked for good. Any guidance on how to diagnose the problem appreciated.

Wouldn’t write it off just yet, have you tried keeping VolumeUp/Down (press middle of rocker) whilst pressing On button and see if you get one vibration or even three if you hold both down long enough? Failing that you may have to get out a heat gun to remove back cover to allow you to disconnect battery.

Well since the phone is apparently still under warranty I have decided to send for repair. Hope they will be able to reflash it.