[] Contact Sync does not work - backup insufficient

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (XA2, Xperia 10…): Jolla C
REGRESSION: (compared to previous public release: Yes, No, ?):


After upgrade to syncing contacts with google-account does not work.
Restoring from Backup at least fills People-Database.


upgraded Jolla C


  1. upgrade to new version
  2. backup in progress of installation
  3. restore backup after upgrade


Contacts as before upgrade


Contacts only in People


Although, after restoring the backup, contacts in People are shown they are not shown in the Phone app and WhatsApp does not add these contacts as well.

That said, you also write

But you also wrote:

So, is it that you are not getting your contacts from the Google server to the phone at all by syncing (only from the backup - which does not, by the way, save any synced contacts but the local ones)?

Or is the problem that although the “Google contacts” are synced/downloaded to the phone, Whatsapp does not get them (but they do appear in People app).

Please clarify.

Did you happen to see the disclaimer below in the generic known issues of the release notes:

4.0.1 update will remove your synced contacts - please re-sync your accounts to get them back! So, go to Settings > Accounts, long-tap an account and take ‘Sync’. Repeat to all of applicable accounts. Check People app, then. Also, restart your phone to see the contacts in Phone > People.

Okay, seems like I only read the hint in the Update-screen and not the whole generic known issues section.
Nevertheless, after Re-booting the contacts seem to be okay now. And WhatsApp is adding the contacts too :slight_smile:

Thanks for the information.

I have one contact that is in People and in Whatsapp, but doesn’t sync their name across, just shows their number. All others are fine. Was working before update, not now. Sony X. :frowning:

I do have similar contacts and found out, that looking into People they have two Address books shown below the name: Phone and Google. And in Phone there is no Telefon-Number, only e.g. email and in Google there is the Telefon-Number.
Weird behavior IMHO !?!
I then have to edit the contact, choose Google and accept the content ?!?
Why isn’t this done automatically?

Btw: adding contacts to WhatsApp is another story on its own :-/

Have you tried any of these solution mentioned in this article: Google Contacts Not Syncing On Android
Here are several options to fix this issue. So, give it a try, and let see if it is useful or not.