[] Regression: Unable to update android apps manually

Sorry if this was already asked. I normally install android apps manually via apk files (e.g. Firefox, Wire, Threema). Since SFOS 4 I can not update the installed apps anymore. Not via GUI (internal filemanger) or CLI apkd-install.

Does some one have a work around? Does this have to do with sailjail?

I also placed the apk file into Downloads (instead $HOME) and tried apkd-install -> no update.

1 Like

I use Threema without Google , installed directly with an apk from the Threema site. A few days ago there was a message that there was an update and then it was installed without problems after confirmation.

I have similar a problem. I can install(update android apps with F-Droid and Aurora, but I cannot install any .apk via File Browser (the fork by @ichthyosaurus) or the build-in file manager (I also tried with Filecat by @leszek ). There simply is no option to “Install”, there is the option to “Open”, but this does nothing. I tried through terminal with apkd-install, it gives me the message below.

method return time=1615222137.017448 sender=:1.34 -> destination=:1.331 serial=26 reply_serial=2
boolean true

XA2 Dual sim, SFOS, but I think (not 100% sure, though) I had the same problem with the previous proper SFOS version (3.4 or whatever it was).

@mcwine - If I understand it correctly - the notification (top bar with install info) is broken right now but the the app gets installed. So, if you deinstall your app and install it newly, then it gets installed (via filemanager in system preferences or right out of the download list, or manually via apkd-install works), but if the app is already installed, no update will be done.

@Bellini, yes, in-app update works. I assume it works because its running already in the valid namesapce and wenn an apk-file update is performed the namespace is not changed or valid. Its clearly a regression because this works flawlessly with SFOS 3.x. So, I guess maybe sailjail is the malefactor but here ends my expertise and some input from Jolla would be great. Above all the next update will be in months. So, a workaround would be great …

You are right, when I tried installing a new android app with apkd-install in terminal, the installation indeed went through. Thanks for clarifying this.

Nevertheless, the problem with file managers is still there, file managers do not give me the option to install .apk files. Perhaps it is a file association problem? (So I guess it is not really related to the original issue, and I should create a new thread)…

Is there currently a way to update Android apps manually at all (via file manager or with apkd-install)?
Or do I need to remove and reinstall?

It seems to be a problem with the mime-type. When I run it on my desktop I get the correct mime-type:

$ xdg-mime query filetype WhatsApp.apk 

Running that same command on my XA2 with the same file uploaded with sftp I get this:

$ xdg-mime query filetype WhatsApp.apk 

Looking at the source code of the File Browser, it seems to handle this as a zipfile and shows the contents when opening. For the same reason it doesn’t offer “Install” as an option in the pulley menu.

In case the file-manager doesn’t offer you an install option, you can run it as:

devel-su apkd-install package.apk

And thats the problem: apkd-install does not work anymore. I hope that the next update will solve this …

Aha, that sounds like 2 bugs then :slight_smile:
Very confusing by the way…

To confirm the broken updater, I did try to update whatsapp while it was running. It does get removed from view and restarted, but still lists the old version in “About” text.

Thanks for finding this! It was just a UI-label thing which I fixed for the upcoming version of File Browser. All files are opened with xdg-open though, so the real problem is in the system. (I suspect it has something to do with the new sailjail…)

Ah, thank you :slight_smile: :+1:

1 Like