[3.4] Lost mime apps system association

Hi all

My case is not really a bug, i lost all the system application mapping since few days, and i dont know how…

when i try to open a zip from browser or a calendar in mail i have error like

“File type… is not supported”

i tried to reinstall libcontentaction-qt5, but problem is the same. I cant find mimeapps.list file in my device.

try to reset mime with mimer apps, but nothing works

Anybody have a solution ?
thanks

I do not have this mentioned file mimeapps.list on my device.

Did you fiddle with anything in the last days? Out of the blue I would not expect such thing to happen…

Maye a reinstallation of package
shared-mime-info
may help?

I tried to reinstall package about share-mime-info and other xdg related package but no change =(

Try running

/usr/bin/update-desktop-database ~/.local/share/applications

from terminal.

Thanks for reply

i tried

nemo@OnePlus5 ~]$ update-desktop-database .local/share/applica
tions/ -v
Search path is now: [.local/share/applications/]
File “.local/share/applications/sailfish-browser-Munin-0.deskto
p” lacks MimeType key
[nemo@OnePlus5 ~]$

but always same issue all association seems broken from apps

Always same problem

Mime association seems good - example for PDF

[nemo@OnePlus5 ~]$ xdg-mime query filetype Downloads/ProtocoleSanitaire2021.pdf 
application/pdf
[nemo@OnePlus5 ~]$ xdg-mime query default application/pdf
sailfish-office-openfile.desktop
[nemo@OnePlus5 ~]$ 

In fact the problem is only in apps

All attachment in mail fail to be open, with the message “File type… is not supported”

I can debug apps to have more logs (no error in journalctl)

I found my problem !!!

This file was missing

/usr/share/applications/mimeinfo.cache

Thanks to my old Jolla1 for help :slight_smile:

1 Like

That file can be regenerated by

$ devel-su
# update-desktop-database