[3.4.0 onwards] Bluetooth turning on doesn't work

Bluetooth worked for a while sort of stable. Now it disconnects my Headset randomly while I am talking and I can only reconnect after having restarted the phone. Now I use my old Nokia 700 again without a problem. PLEASE @Jolla do something about this problem. This is really enervating!

2 Likes

it is the hciattach process that remains running - I reported this, but don’t remember if I got an answer.
And I agree with you - the unbelievable thing is that it is not tested, because many things were changed with 4.1 - however the damage is massive :confused:

2 Likes

Similar issue as reported by Helly2 here with freshly-flashed Sailfish 4.1.0.24 on Sony Xperia F5121: Right after device reboot, BT coupling works (mostly), but it fails on subsequent connect attempts. Some of the side effects described in this thread are observed too (“blinking”-freeze-in).

Jolla people, please fix this bug!

@jiit, @jovirkku: Do these two independent posts mean that there are two bug reports about this?
Also, do you still need any logs? Could you share what you already know about the causes of the issue?

@deloptes would you like to elaborate a bit on what you found out about hciattach?

I’m afraid that the Xperia X won’t get that much priority right now. Maybe someone in the community is able to find a fix for this with the collected information.

I found this also on the 10 II with latest and greatest. Unfortunately it makes 10 II unusable for me despite the high price I paid.
It is independent of the hardware version (at least for me - see my reports from may!!)
It started with 3.4 which I tested on another Xperia X. This is why I keep 3.3 on the daily phone.
Some people reported they are unaffected, although I am not sure. I observe the same on the X and 10II

what I observed is that when

  1. you click the BT button but it does not remove the hciattach process. The button turns off.
  2. Next time you click the BT button it tries to enable hciattach again, but since it is already running it fails and can not work properly

Only work around is to kill hciattach before clicking the BT button, but not easy for avg. Joe

I’m not seeing the problem any more on 4.2 Verla on Xperia10 ds.

Can people please confirm/deny this is working now?

I believe the situation has improved some, and for some time I’ve only needed to reboot my 10 II once in weeks (due to the Bluetooth not getting on). However I haven’t been using flightmode since this problem appeared, ie. I haven’t been turning bluetooth off pretty much at all so I’ve been avoiding the whole issue.

It’s much better now, but I had to reboot whole phone few times, because turning on of the Bluetooth didn’t work.
As @laustela wrote, it’s much better to keep it turned on :smiley:

With 4.2 on Xperia X the issue still persists.
Sometimes killing hciattach helps, otherwise only restarting bluetooth-rfkill-event.service once or even twice makes Bluetooth connectable again.

you got lucky, it seems :wink:

1 Like

Well, if any of you would like to contribute to or improve anything wrt either the patchmanager patch, or the PR against sailfish-utilities you’re welcome to do so.

I don’t have a great many devices to test and as we have seen there’s a lot of guesswork involved .

What’s missing here is hints for low level debugging. I’d be eager to comb through logs if only I knew how to get some.

Sometimes BT won’t work even though there’s no hciattach process running. Then the said service restart is necessary. But my observations are not done in a systematic way.

This problem persists in the Xperia X. It’s a pain to be sure.

IMHO, Jolla should simply include a complete BT kill/restart as part of the tools, like there is for networking

/rant

BT is and always has been flakey, and not just on SFOS. Connectivity and interoperability have been the defining characteristic of BT since its invention and apparently this isn’t going to change any time soon

Just as I typed in above that it had improved…

Yesterday I had to restart my 10-II (due to other issues). I was not able to turn on bluetooth. I restarted the phone. Twice. Still no go. I shut down the phone (as I seem to remember that it sometimes need a full shutdown instead of restart) and STILL nothing. I had to manually run ‘systemctl restart bluetooth.service’ and then I was finally able to get it back on :angry:

In my case, the main problem with turning off bluetooth was, that the hciattach process could not be closed by bluetooth-rfkill-event.

Okt 31 11:34:34 Sailfish bluetooth_rfkill_event[654]: free_hci(bluetooth_rfkill_event.c:906): killing hciattach failed

If the process hciattach was ended manually after switching off the bluetooth (kill -15 hciattach), the reactivation of bluetooth worked without any problems.

The reason why the hciattach process cannot be closed by bluetooth-rfkill-event is likely following:
The bluetooth_rfkill_event uses the command ‘killall --wait hciattach’ to end the hciattach process.
Because of the switch to BusyBox, the killall command from BusyBox is used instead of the killall command from the psmisc-tools package.
However, the BusyBox ‘killall’ command does not support the ‘–wait’ option, so it generates an error and will not be executed.

As a workaround, I installed the psmisc-tools package.

devel-su pkcon remove busybox-symlinks-psmisc

The hciattach process is now correctly terminated by bluetooth-rfkill-event

Okt 31 17:28:38 Sailfish bluetooth_rfkill_event[10297]: free_hci(bluetooth_rfkill_event.c:906): killing hciattach succeeded

Switching Bluetooth on and off now works properly again.

Tested on Xperia X (F5121) Sailfish 4.2.0.21 (Verla)

10 Likes

Thanks for your investigations @senders. That looks interesting to me. I’ll point it to one of our chief engineers.

6 Likes

After update to 4.3.0.12 on my XperiaX F5122 Bluetooth is now completely broken and will not activate at all.

It was flakey before as many have noted.

This functionality has now reached unusable, which is a bummer, because I just flew half way around the world unable to use my BT headphones and hear my music

I don’t know how to bump this … I can’t believe that this problem get successively worse with each version

That didn’t help me … still no BT whatsoever

systemctl restart bluetooth-rfkill-event.service

This worked in this instance … now I’ll try to connect to something

I use the command shared by @peterleinchen a few months ago (basically restarting both services). I need sometimes to run it 2 or 3 times but it always ends up working:

devel-su restart bluetooth bluetooth-rfkill-event