3.4.0 Manual Backup to OneDrive

REPRODUCIBILITY (% or how often): 100%
BUILD ID: 3.4.0
HARDWARE (Jolla1, Tablet, XA2,…): Xperia X
UI LANGUAGE: English
REGRESSION: (compared to previous public release: Yes, No, ?): Yes

DESCRIPTION:

When trying to backup mnually to One Drive, the upload fails each time

PRECONDITIONS:

STEPS TO REPRODUCE:

  1. Go to Backup
  2. Select manually backup to One Drive
  3. Upload of the file fails

EXPECTED RESULT:

Upload succesfull

ACTUAL RESULT:

Upload of the file fails

ADDITIONAL INFORMATION:

I deleted my OneDrive account and recreated it but the issue persists.

3 Likes

Can reproduce on Xperia 10

We cannot reproduce this internally; could you provide logs?

Yes I can provide logs if you tell me how to :slight_smile:

I had a similar problem with backup to NextCloud, the problem was that the backup destination was empty in Advanced settings – recreating the account filled in that information, and backups started working again.

I can confirm the same on X10+
I also deleted and recreated my onedrive account
I tried to remove all previous backups
but it does not seem to help so far

@jiit Uploaded logs here: https://nextcloud.webo.hosting/s/88GxSrxYzkfpewr

1 Like

Thanks for the logs. We have a bug report for this now.

1 Like

You log has:

> 20:55:43 Sailfish p[28209]: [W] unknown:0 - [sailfish-backup] "Requesting sync profile onedrive.Backup-32 to upload file /home/nemo/.local/share/system/privileged/Backups/onedrive.Backup-32/sailfish_backup_2020-09-30T17-55-28Z.tar.gz"
> syys 30 20:55:43 Sailfish p[28209]: [W] unknown:0 - [sailfish-backup] "Status: UploadingBackup"
> syys 30 20:56:08 Sailfish systemd-journal[690]: Suppressed 1 messages from /user.slice/user-100000.slice
> syys 30 20:56:08 Sailfish onedrive-backup-client[28459]: [W] unknown:0 - ERROR:  "Backup" request with account 32 experienced error: QNetworkReply::NetworkError(UnknownContentError)
> syys 30 20:56:08 Sailfish onedrive-backup-client[28459]: [W] unknown:0 - ERROR:  failed to backup file: "/home/nemo/.local/share/system/privileged/Backups/onedrive.Backup-32" "sailfish_backup_2020-09-30T17-55-28Z.tar.gz" to: "Backups/Xperia-10---Dual-SIM_m1n_Oy7nYBvp" for OneDrive account: 32 , code: 413
> syys 30 20:56:08 Sailfish p[28209]: [W] unknown:0 - [sailfish-backup] "Cloud operation backupToCloud for profile onedrive.Backup-32 sync status changed: 4"
> syys 30 20:56:08 Sailfish p[28209]: [W] unknown:0 - [sailfish-backup] "Status: Error"
> syys 30 20:56:08 Sailfish p[28209]: [W] unknown:0 - [sailfish-backup] "Status text: Virhe: tiedoston lähettäminen epäonnistui"
> syys 30 20:56:08 Sailfish onedrive-backup-client[28459]: [W] unknown:0 - ERROR:  Cloud backup error was: "CloudUploadError" "onedrive.Backup-32 update failed, details:\u0001"
> syys 30 20:56:08 Sailfish onedrive-backup-client[28459]: [W] unknown:0 - ERROR:  busy semaphore is negative for account 32
> syys 30 20:56:08 Sailfish p[28209]: [W] unknown:0 - [sailfish-backup] "Error! error=CloudUploadError errorString=onedrive.Backup-32 update failed, details:\u0001"

There was this: QNetworkReply::NetworkError(UnknownContentError)

Was your internet connection ok at that time?

I have tried the backup multiple times with both Onedrive and Nextcloud. With Onedrive it never succeeds, while with Nextcloud it always does. So, I believe it is not the network.

I don’t know if this has something to do with the issue, but it seems the backup process creates a new folder into the OneDrive cloud.

Originally, there is the folder where my old device backups are, Apps>Sailfish OS>Backups, in which are separate folders for the devices (Jolla_[xxx], Xperia_X_[yyy] and Xperia_10—Dual-SIM_[zzz]).

Once I try to run a new backup on Xperia 10 with 3.4, a new folder appears in the cloud: Apps>Sailfish OS 1>Backups>Xperia-10—Dual-SIM_[zzz].

I also have problems with OneDrive.
I can successfully log in to OneDrive for a short time, but seconds later I get the error message: “Account not logged in”.
It is possible to log in again - but only for a few seconds until the error message appears again.
Manual data backup is also not possible and ends with the message: “Error: Could not upload file”.
Data recovery is also not possible.
Error: “Cannot connect to cloud provider”.
Strangely enough, however, I can access the OneDrive storage via the Android OneDrive app.

1 Like

Maybe sailfish use the onedrive simple rest api.

“The simple upload API allows you to provide the contents of a new file or update the contents of an existing file in a single API call. This method only supports files up to 4MB in size.”

I tested Backups and Photos with OneDrive both doesn’t work. Doesn’t matter if the OneDrive account is protected with 2FA or not.

With 2FA enabled, every action will cause a re-login, which opens the browser, checks that the login is still valid and closes the browser again. Annoying.

Have you tried so called Device password with 2FA? Under Microsoft account security settings you can generate device specific password to use with software which don’t support 2FA. I don’t remember exact place since it’s been a while last needed it.

PS. I haven’t added Onedrive account my self, but I use hotmail via exchange.

Unfortuantely device passwords didn’t work with OneDrive.

Also a problem with Gemini

SOLVED

Restarted network services using Utilities
Forgot WLAN settings
Entered WLAN connection manually (no networks visible in Sailfish 3.4.0.24)
Entered Backup and started Manual backup to OneDrive

Unfortunately this didn’t work for my J1. In backup I still get: “Cannot connect to cloud service

I have the same problem on my XA2 after the update. Password is not stored and automatic backup of photos and settings to OneDrive is not working anymore.

Edit: “Network reset” using Sailfish Utilities didn’t help.

XA2 here, also not working. Sending to OneDrive fails. Automatic nightly backup also fails.

Backup to Dropbox works.