[] No sound with connected bluetooh headphones Bose QC 35 II

REPRODUCIBILITY (% or how often): always
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (Jolla1, Tablet, XA2,…): X10 Dual Sim
REGRESSION: (compared to previous public release: Yes, No, ?): Yes


Bluetooth successfully pairs and connects to the headphones but no sound is being played, neither with Brave browser (android) nor with the Sailfish Browser. Phone speakers are also quiet so the phone seems to recognize the headphones.

This worked in Sailfish 3.3 and previous.

Tried forgetting the device, resetting the headphones, re-pairing. Restarting the phone, nothing helps.

Connecting with other devices (e.g. a JBL flip BT speaker works).

My Xperia 10 Plus dual-SIM (I4213) that has a development version of the upcoming Sailfish OS release, works fine with Bose QC 35 II.

Bose keeps working with, as well.


I ran into this same issue after updating to Koli–posted in the release note comments but moving the discussion over here so as to not clutter that thread, and since this seems like the same issue.

Curious–I got my pair of headphones last spring, and the update to 3.4 didn’t cause any issues for me. So, you might be right but there seems to be some other contributing factor since it happens for some but not all. That rules out my guess that it could be related to the firejail sandboxing & permissions though, since it sounds like the same issue happened during a previous update too.

Type: Headset
[x] Always allow connections from this device
Supported profiles: SPP, HSP, A2DP, AVRCP, HFP, PBAP, DID

I wonder what bluetooth audio profile it uses–is there any way to check that from e.g. the command line? Not really very familiar with bluetooth audio.

Edit: checked pactl list output and it reports the relevant sink as bluetooth.protocol = "a2dp_sink", and in general the output seems to match what I’m seeing on my laptop (also using pulseaudio) where it works just fine. The only difference I can spot is

(laptop): headphone-output: Headphone (type: Headphones, priority: 0, available)
(sailfish): headphone-output: Headphone (priority: 0, available)

which I think isn’t anything important, might well just be differences in output due to different PA versions or so…

@spark did you ever resolve/figure out your issue, or is your headset still not working with SFOS?

Works fine for me here with Koli with a QC 35 2. But I did not have it paired previously, so I paired it from scratch.

With BT problems, it is always good to try this simple procedure first:

  • delete pairing
  • turn BT off on both devices
  • turn BT back on
  • pair the devices.

Please note that Bose QC 35 2 can have only two devices paired with it at the same time. If the quota of 2 is full, further pairing attempts will fail. In such a case one should delete the previously paired devices from the Bose headset first.

My QC 25 2 is currently paired with 5 devices.

Really? My device stops at 2.

Yes. I don’t know why, but it just works for me. The Bose Connect App (on an Android device) shows all five devices and the headphones are trying to contact all of them on startup. Although I have installed a firmware update recently, it worked from the beginning since years (but maybe I have installed a firmware update back then as well).

Ok. It may be that I have something wrong, or that some devices were shipped like that. It could be that some other people may have a similar feature/status with their headsets. And then they fail in Bluetooth pairing (if they have paired with 2 other devices already).

I think that you can connect it to two devices simultaneously, not pair it.