3.4.0.22EA: Jollaphone (JP1301) + tohkbd2, enable services after update

If you are still using the Jollaphone (the first one) with a tohkbd2 keyboard, the keyboard does not wort after the upgrade to 3.4.0.22EA. To make it work again open a terminal and enable and start some services:

devel-su systemctl enable tohd
devel-su systemctl restart tohd
devel-su systemctl enable harbour-tohkbd2
devel-su systemctl restart harbour-tohkbd2

After this it should work again.

3 Likes

Thanks! Is this actually a bug or is it intentional?

The harbour-tohkbd2 service has to be restarted on every boot (the other steps only need to be done once), so it does seem to be a bug.

Edit: maybe only sometimes. I had to do it thrice in a row, but then the next boot it started on its own.