[3.4.0.22] XA2 phone calls no audio

I think I may be getting this issue more often since the recent update than before. No audio for both ends until a reboot. Then it lasts for a random amount of time before reoccuring. XA2 Ultra. I have voted above.

I’ve not tried the attempted fix yet, will try and do that at some point.

I have the same problem. First time ever, never before. I didn’t try ‘this setting’. But I answered the question and seem not to be able to get it unanswered.

I had to reboot three times.
But I’m used to reboot to get things to work. Most times after a reboot Wlan and sim card won’t activate (greyed symbols in top of screen). After two or three reboots Wlan and Sim symbols become active.
And now I have this new test: Call myself if I have audio on a call.

If this ‘no audio with phone call’ occurs again frequently I will try ‘this setting’.

I also had the same problem. Im using XA2 with only one SIM. The other SIM slot is empty so I unactivated it in settings. Problems started soon. No sound on phone calls and mobile data problems. I activated the empty SIM slot in settings and everythings fine.
I dont say this is answer for your problem but solved mine

Having the same issue, this hint cures it.

1 Like

I still have not had this issue re-occur since applying the pulse audio timeout setting about 3 weeks ago. I’ve certainly received a number of phone calls over this period and would normally have experienced the failure. I’d really encourage everyone watching this thread to try the fix and share their experiences (maybe after a week or so of use) in the poll.

1 Like

I, too, enjoy this amazing feature more frequently now which I thank everyone involved greatly for.

I had this issue intermittently with 3.3 and I used some commands published in TJC to (re-)install pulse audio and then restart the phone. That was the only combination of actions that fixed it. With 3.4 I got the problem maybe twice, so I would say there is an improvement although the problem is sadly still here.
In the case of 3.4 a running the pkcon -i pulseaudio didn’t have any effect, (IIRC it didn’t reinstall it) and a phone reboot fixed the problem. The 2nd time I got it I just rebooted the phone and it was fixed, so the behaviour has definitely changed compared to 3.3. I am using and XA2 Dual SIM.

Hi, same with my phone XA2 dual. Since the latest update (3.4.0.24) there is once or twice a day no audio when answering or doing a phone call. Before the update there were no problems.

On 3.3 I ran into this bug quite regularly but could fix this issue by restarting the phone.
Beginning a few weeks before 3.4 upgrade that method didn’t help anymore and I had to take the SIM card out, restart it and insert it again.
I didn’t experience it since the 3.4 upgrade.
XA2

edit: I didn’t fiddle around on system level or installed non harbour apps, except of android ones

1 Like

Also my major worry with SF on XA2 all the way up to v3.4 in daily use. Have had this bug trying to answer calls while unplugging from charger or USB connected computers or sometimes just out of the blue. And it happened in different countries, so might not depend on a certain type of network. Adding timeout setting mentioned earlier resulted in no sound / microphone at all during call … maybe had a typo?!

Thank you for all of your responses. Because of these I felt confident enough to make a switch to XA2 Dual-SIM on Tuesday evening. With 3,5 day uptime and after roughly 10 calls, I haven’t experienced this yet. I have only first SIM enabled, in case that makes any difference, and haven’t made fix mentioned.

@mattpenn thank you for your efforts to make a poll. That really helped. So far I’m very happy with my device. :relieved: Jolla1 got it’s deserved retirement after almost 7 years. :man_white_haired:

2 Likes

It did not change anything for me. I still have this issue after a reboot and then after a subsequent reboot the problem goes away again. XA2 dual sim. SFOS 3.4.

2 Likes

I’m rather dismayed to report that I had this issue reoccur for the first time since applying the pulseaudio setting. It also didn’t get fixed after the first reboot, only the second :frowning:

2 Likes

I think as well that the changed pulseaudio service-file has no effect. It occurred several times since then. Once even 5 reboots where necessary to fix the issue. In the journals there are several interesting lines, especially the last 4 ones:

Dec 20 14:34:08 Sailfish telepathy-ring[4151]: trying to create call to "+XXX"
Dec 20 14:34:08 Sailfish ofonod[3045]: dialing "+XXX"
Dec 20 14:34:08 Sailfish kernel: binder: 3045:26274 got transaction with out-of-order buffer fixup
Dec 20 14:34:08 Sailfish kernel: binder: 3045:26274 --> 6528:0 transaction failed 29201/-22, size 284-48 line 2442
Dec 20 14:34:08 Sailfish mce[2872]: tklock.c: tklock_datapipe_uiexception_type_cb(): uiexception_type = none -> call
Dec 20 14:34:08 Sailfish telepathy-ring[4151]: call create request to "+XXX" successful
Dec 20 14:34:08 Sailfish kernel: binder: 3045:26274 got transaction with out-of-order buffer fixup
Dec 20 14:34:08 Sailfish kernel: binder: 3045:26274 --> 6528:0 transaction failed 29201/-22, size 284-48 line 2442
Dec 20 14:34:08 Sailfish kernel: send_afe_cal_type cal_block not found!!
Dec 20 14:34:08 Sailfish [4158]: [D] unknown:0 -         Type: "org.freedesktop.Telepathy.Channel.Type.StreamedMedia"
Dec 20 14:34:08 Sailfish [4158]: [D] unknown:0 -         Interfaces: ("org.freedesktop.Telepathy.Channel.Interface.DTMF", "org.freedesktop.Telepathy.Channel.Interface.Hold", "org.freedesktop.Telepathy.Channel.Interface.Group", "org.freedesktop.Telepathy.Channel.Interface.CallState", "org.freedesktop.Telepathy.Channel.Interface.ServicePoint", "org.freedesktop.Telepathy.Channel.Interface.Splittable.DRAFT")
Dec 20 14:34:08 Sailfish lipstick[4404]: [D] onDestruction:267 - coverActionIndicators destroyed voicecall-ui.desktop
Dec 20 14:34:08 Sailfish lipstick[4404]: [D] onCompleted:263 - coverActionIndicators created voicecall-ui.desktop
Dec 20 14:34:08 Sailfish kernel: HTB: quantum of class 10010 is big. Consider r2q change.
Dec 20 14:34:08 Sailfish kernel: qdsp_cvp_callback: cmd = 0x13198 returned error = 0x1
Dec 20 14:34:08 Sailfish kernel: voice_send_cvp_topology_commit_cmd: DSP returned error[ADSP_EFAILED]
Dec 20 14:34:08 Sailfish kernel: voice_setup_vocproc: Set topology commit failed err:-131
Dec 20 14:34:08 Sailfish kernel: setup voice failed

I’m happy to provide the complete logs to the developers but not publicly. These logs are from a XA2 Plus Dual SIM with SFOS 3.3.

2 Likes

This problem hit me today. Couple of reboots and editing pulseaudio.service helped for now. (3.4.0.24)

3 Likes

I’m still getting this issue and it takes several reboots to get my phone back in working order.

Have Jolla commented on the that fact that previous OS updates have never resolved the issue or made any comment about the fact that some of us cant call people on our phone?!

1 Like

Yes. @jovirkku commented a few times here in this thread, so Jolla is aware of the issue, and especially of the fact that neither updates nor proposed workarounds fixed the issue.

1 Like

Yes, he did…

…but about this -Jolla as a company- I am not sure.

Reason why this topic is really urgent, imho:

Else one would need to go via zendesk and this may help single person but not community wise.

2 Likes

I agree that while the input on a workaround to attempt was welcome I think this issue is critical enough and has been live long enough to warrant a more verbose update from Jolla. This bug was identified several releases ago and was even at some point listed as resolved. What is understood about the issue? What has been done so far and what is being done right now to resolve this in the next release?

4 Likes

28 days and it happened again. This is bad.

Have you managed to repeat this problem at Jolla? If not, I’m willing to let you access my phone while the problem is on so you can take a look if that helps finding out the cause.

You have my email address.

3 Likes