[] python3-sqlite missing

I think so, it would cause sqlite bindings to be installed with the app thus allowing it to function for the user without any manual intervention.

I opened an internal bug report about this with slightly different wording, i.e. suggesting that python3-sqlite should be allowed in harbour.


Thank you very much for opening this thread! It was easy to find and the proposed workaround you provided made me happy. Thanks a lot lad!

Thanks @vige for the prompt action python3-sqlite is now an allowed dependency.

Vige or someone else is there a way to do SFOS version in the dependencies because SFOS < 3.4 does not have python3-sqlite and harbour does not allow setting a package for SFOS >= 3.4.

python3-sqlite does not seem to e available for me?

pkcon install python3-sqlite
Resolving                                                                                                                            [                                                                 ] (0%)  Package not found: python3-sqlite
Command failed: This tool could not find any available package: No packages were found

(yes, I was having a refresh previously)

Always good to be able to reply to yourself…

ssu re was set to 3.4.0. After manually setting it to and refreshing, it is available now. Probably a side effect of my previous upgrade issues.

@vige it seems that maybe the ideal resolution of this issue is not allowing python3-sqlite but undoing the change made in or making python3 depend on python3-sqlite (and any other python package that was separated) so that it is automatically installed.

Why do I say this?

  1. python3-sqlite does not exist on SFOS < 3.4 thus we now either need to package twice or have a conditional dependency, however I have so far not been able to find a symbol provided to RPM that indicates SFOS version. Another altrnative may be boolean dependancies, but I’m not sure that the differences in version numbers between SFOS < 3.4 and SFOS >= 3.4 are sufficient to allow this.
  2. There is sadly no lack of abandonware in the Jolla store, unless the user has a maintained program installed in addition to these that does install the needed python packages their dependencies will never be provided and the program will stop working.

OTOH - it could also be legitimate to allow stuff to break, but in that case there is really no excuse anymore to keep the harbour dependencies so limited.


https://gitlab.com/cy8aer/podqast/-/issues/26 I tried every possibilty but nothing worked for podqast.


As far as I understand, when this version of pyotherside will be installed, the sqlite binding will be pulled automatically. I see this as a way to install automatically the bindings on SailfishOS.

But that has consequences anyways: sqlite3 is a standard library simply shipped with python. So Jolla removes standard libraries without any warning. And because it is a standard library it cannot be installed by pip . The certificate handling in matrix-nio (my bluepill library) depends on a working sqlite3 support. If there is no change or a working recipe from Jolla i must cancel any further development.It is complicated to hold everything together even if there is sqlite3 existing. Next week they change to python 3.9? Ok, then I need to redesign the thing and bring it out for this version up. How many versions should I support?

They tell us: “don’t use this, don’t use that” but then they are not consequent with their own library setup. If they tell: you can use standard python then they cannot cut standard python stuff out.

I must officially say: this system is dying for me.

Life will be better without smartphones!

1 Like

My systems all depend to pyotherside. No automatically installation of sqlite. Try it out:


And when will this patch be available? With SFOS 3.6 or 3.7? The actual SDK doesn’t have this patch. Try it out.

1 Like

This will come with a version of pyotherside that is not in But Jolla people created a dedicated branch in the project to support the 3.4.0 version, so I guess there will be a new release candidate one day:

1 Like

One day? Where is their official statement. I am killing ressources for that. Bluepill needs about 30MB libraries (libolm) and python stuff (matrix-nio) which I need to pack into the app. I am not even sure that this will be accepted in harbour. Do they really think that they can ever support crazy good apps? Forget it.

@cy8aer This may help you for now:

Though it is not harbour compatible according to the SDK.


thanks for that. I’ll try it out. Is it harbour compatible?

Not according to the SDK, haven’t tried to upload to harbour yet, just added a note referring people to OpenRepos.

1 Like

‘python3-sqlite’ added to


Can someone test podqast with please? Without python3-sqlite the library does not work.

I tested with a fresh install device in .24 with only your repository enable

podQast run well :grinning: (add new url, play episode)

1 Like

Just to clarify what happened: the python3-sqlite package is now a dependency for the pyotherside package. It’s not included in the images, but any app which uses pyotherside should pull it in. So it shouldn’t be necessary to make any modifications to the apps.