Out of space while upgrading and now stuck [Solved]

I decided to upgrade my Xperia 10 Plus to from the command line, as I always do. I had approximately 330Mb free on / and 38Gb free on /home. I thought it was enough. It wasn’t. version --dup complained about approximately 150Mb needed halfway through the process of installing the downloaded packages, couldn’t install one of them, retried a couple of times till I stopped it with Ctrl-C.

I uninstalled some unneeded, space-consuming packages with rpm -e and now I have 490Mb free on /, the phone is up, but it is in an inconsistent state: if I try version --dup again, it complains about not being able to start org.freedesktop.PackageKit and tries 9 times without success . pkcon doesn’t work either, it says Error calling StartServiceByName for org.freedesktop.PackageKit.

If I try to start /usr/libexec/packagekitd manually, I get the error

Failed to load the backend: opening module zypp failed : /usr/lib/packagekit-backend/libpk_backend_zypp.so: undefined symbol: _ZNK4zypp3sat10LookupAttr8iterator9dip_equalERK13_DataiteratorS5_, version ZYPP_plain

I don’t know what to do: would a simple reboot put me in a working state where I would be able to complete the upgrade, or (more probably) would it simply fail and force me to use a recovery shell, in a more limited environment than I am now? Is there something I could try from the (somewhat working) system I have now? Do I have to reflash all and that’s it? (I do have a backup of everything)

I am posting under General because I am not reporting a bug, but simply asking for help in a situation of my own making.

Thank you in advance for any advice.

I do not have the knowledge to help you here, but shouldn’t you free up more space than that? On the xa2 the update was over 600 mb and I’d reccomend freeing up even more. Before updating I checked settings/storage/system data and made sure to have some 900mb free there - probably overkill…

@enrish Thank you for your comment. The update is over 600Mb on the 10+ as well, but it ends up on /home , which in my case has 38 Gb free (and in the release notes they recommend at least 3 or 4 Gb). In fact, as I will explain in a general answer I am about to write, I succeeded in completing the update with 490Mb free on the root filesystem /. Unfortunately, it is not very clear that two different filesystems are involved, each with its own different free space requirements.


Success! I was already at a root prompt and I did the following,

cd /home/.pk-zypp-dist-upgrade-cache/
rpm -U $(find . -name '*PackageKit*.rpm' -print)
cp -p /usr/lib/zypp/plugins/urlresolver/ssu /usr/libexec/zypp/plugins/urlresolver/
version --dup

And this completed the update successfully. I crossed my fingers, rebooted and almost everything was OK. After rebooting, with already running, I did

pkcon refresh
pkcon remove harbour-storeman
pkcon install harbour-storeman

And Storeman worked perfectly.

From other users’ post I expected to lose all my saved Wifi networks and VPN’s. The solution which worked for them

pkcon install python3-sqlite

didn’t work for me. Never mind, I have all passwords backed up somewhere else, so it’s only a minor nuisance to have to type them in again.

Maybe other problems will surface, but I am happy now.

I wish to thank all forum users whose posts provided hints for the above solution. I am going to like their posts.