[] Jitsi and ancestors still not streaming

REPRODUCIBILITY (% or how often):
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (Jolla1, Tablet, XA2,…): XA2
REGRESSION: (compared to previous public release: Yes, No, ?): Never

Jitsi and other WebRTC based android apps do not stream.



Installed jitsi app, e.g. from f-droid, working jitsi client, e. g. browser.


  1. Start Jitsi client
  2. Enter the connection string from the partner client
  3. start video (click video icon) and or audio (microphone)


The connection is opened and both can see video and listen to audio


The connection is opened, video is black, no audio


according to the tjc-post there are many applications which have the problem. All of these use the WebRTC mechanism for streaming.

I guess, this bug/feature indicates if we have a Covid pandemic: If it is fixed the pandemic is over (but we need this feature in the pandemic)


And think about that: We will never have the allowance in harbour to legally use the gstreamer webrtc plugin. So a legal app for webrtc is a no go.

1 Like

By saying “still not streaming” I assume it did not work also on 3.3.x. My SF-phone is still and Element 1.0.8 is installed from F-Droid and video calling to other Element instance under Android works fine. As far as I understand, P2P video calling in Element is pure WebRTC.

However as both phones have degooglified Elements, then Firebase-based push notifications do not work and you have to keep in mind to let the calls to ring long enough for the notification at receiver’s phone to appear (if receiver’s Element is in focus, then notification is instantaneous). [Maybe I should have a look at setting up MicroG.]

Jitsi is working over the mobile network of vodafone and telekom. Only with Wifi (and maybe the telefonica network) the screen stays black - exactly as found in the thread on TJC. Apparantly this is tracked by Jolla

Did you try Jitsi over the mobile network?

Hm Wifi of course :-/

Ok, works on Telefonica/O2 net :wink: (



So the problem apparently is tied to Wifi

1 Like

Probably NAT. In TJC there was mentioned that the stun stuff is not sent out.

I guess you are right. Wasn’t there a fellow that even got Jitsi work with Wifi after some tinkering with the Wifi router?

Upgraded to from 3 and tried jitsi. Unfortunatelly even with upgraded web browser I get this browser is not supported, plase upgrade to the most recent version. Any ideas when our engine will get upgraded to more recent versions? I also think this engine should be of high priority when it comes to apps upgrade because of all kinds of features and bugs.

1 Like

I guess that this may not work with the browser anyways because it is a mobile browser. I use the Android jitsi from F-droid - but with the known problem that it does not work in local WLANs

1 Like

I had the same with Jitsi, Telegram and Wire. No video calling possible on my Sailfish device.

Calling was possible within Telegram, but it worked within mobile data as if it was a normal call and the sound was very weak.

Threema is another app using WebRTC for calls that does not work on WLANs or any connections with VPN turned on. Since it affects all apps on Android layer that are using this technology and not a single app, hopefully Jolla will notice it and try to fix the problem.

1 Like

please fix it jolla!


I have the same behaviour on my XA2 ( with Jitsi Client (20.2.3) and Threema (4.6.2). Video call is not working with Wifi connection, but with mobile data (even with VPN) it is working. I tried connect to a Jitsi conference via Firefox for Android (95.1.0). This worked with mobile data and surprisingly also with Wifi.