[Xperia 10 II] Unable to reach Recovery Mode

I was following the instructions from https://jolla.zendesk.com/hc/en-us/articles/360021620740

  • Disconnect the USB cable from Xperia 10 II
  • Turn the phone OFF
  • Force your Xperia 10 II or Xperia 10 III to the fastboot mode:
    • ensure that the LED at the top of the display area is lit in BLUE colour
      I get to
      sudo fastboot flash boot_a hybris-recovery.img
      sudo fastboot flash boot_b hybris-recovery.img
      sudo fastboot reboot

Afterwards the Phone is stuck in a reboot loop, and does not show the expected “RECOVERY: Connect USB cable and open telnet to address” at the top.

Tried with Linux and Windows. I always get to the “(sudo) fastboot reboot” part. Device reboots but does not display the recovery mode.

Tried recovery image from and Is there a possibility to get older releases?
I would like to avoid re-flashing the device, but I’m starting to think this may be my only option.

Anything I’m doing wrong or hints/tips you can give me?


No reaction from the Jolla support, no reaction here.
I finally re-flashed the device.

1 Like

Sorry that we missed your original post @Bambustreppe, somehow it feel through the cracks. Were you able to get your device working again by reflashing?

Yes, I did. That was, atleast for me, never in question, though.

I just stepped into this, when trying to recover from nuked defaultuser environment ([Multi-user][Android] User data get deleted and lost, device reset).

I have a Xperia 10 II, with (originally flashed with and neither of the .68 nor .64 recovery images worked. The device is just stuck in a boot loop after flashing the recovery image to a and b sectors and rebooting.

I would like to access recovery mode before reflashing, to see if there’s data worth salvaging.

Jolla, can we expect at least a reply?

@flypig please don’t let this fall through the cracks again :slight_smile:
Or is this something for support to handle? I really like to access recovery mode before reflashing. Right now my phone’s a paperweight and I gladly test experimental images to sort this problem out, once and for all.

1 Like

Thanks for highlighting this again and I’m sorry that you’ve hit the same issue. From our internal bug tracker it looks like there’s currently no workaround for this issue.

There has been some work done on fixing the issue, but that’s still in development and once completed it would still likely only affect future releases.

However, I’ll double check tomorrow in case I can find anything further out; I may be misunderstanding things.


@flypig I have now submitted an official support request (#39005), in hope of enabling closer cooperation for this bug (and accessing any data).

Thanks @Mohjive and sorry for my slow response in getting back to you. I think submitting a support request was the correct step. As far as I can tell, what I wrote before is correct: that any fix for this won’t happen until at least the next release, but working with the Support team will hopefully provide more insight.

Same thing here : Recovery Mode is not accessible via "telnet"

The following freshly flashed “Vanha Rauma” releases won’t provide access to the device’s recovery mode:

■ SFOS release on SONY XQAU52
■ SFOS release on SONY XQAU52

Device is not accessible after “hybris-recovery”-flashes from the “Sailfish_OS-Jolla-” or “Sailfish_OS-Jolla-” packages.
The device stucks at the white-SONY-on-black-screen-logo.

Interestingly, recovery mode is accessible flashing “hybris-recovery” from the “Sailfish_OS-Jolla-”-package. Due to time reasons I have not checked with the releases in between.

Flashing once again “hybris-recovery” from the “Sailfish_OS-Jolla-” or “Sailfish_OS-Jolla-” packages does not show any “RECOVERY: Connect USB cable and open telnet to address” message after booting past the “unlocked boot loader”-Warning and the white-SONY-on-black-screen-logo.

Access to Recovery Mode is essential. The availability should really be testet prior any release. Thanks for fixing it !



would anyone having a recovery version that works ready to share it?
Also, do you believe that there would be risks using an older recovery and then going back to correct boot version?
I need to backup my phone completely before trying to resolve issues by switching back to android and again to sailfish OS.



after an incomplete upgrade attempt I ran into a similar issue. The phone (Xperia 10ii) boots up and asked for the unlock pin, afterwards I’m stuck with a blank screen, and the power button would only allow to switch the LED on and of (to white). I didn’t manage to access the fastboot mode at all - the LED would be lit in white if I connect a switched of device but never turns blue. I don’t mind reflashing the device, I only have to backup the data in the first place. Any hints how to reach fastboot mode or at least ssh into the phone?
Thanks in advance.

I still don’t get any further.
What ist the thing regarding the “data cable” claimed to be necessary to access fastboot mode? I only have a normal usb-to-usbc cable, the same I also used to flash the device initially. Is there any special data cable available?
Thank you!

“Data cable” only means that the data leads are connected (which is the norm). That is as opposed to a pure charging cable, with only power connected (which is quite rare).

1 Like

Thank you.
Any hint anyone, how to get into reco mode (or ssh into the phone)?

So even accessing fastboot mode is your issue?
Are you sure you are holding the correct key? (I think some of the Xperias use different ones).
Try another computer and/or OS.

Moved to the bug reports category. “Tracked”.

Exactly the same behaviour for Sony Xperia 10 III with the current 4.6 / 4.5 public release channel update.
I can not access the recovery mode neighter with exactly the same stuff happening but I do not have any kind of image to go to the recovery mode.

Anybody knows what to do now to go to the recovery mode?

1 Like