"xdg-open" not found

with SFOS 4.4
from the file browser
if i select a file and pull the menu to open it
i get the error message “xdg-open” not found
while typing “xdg-open” in the terinal i can see xdg-open is there

this used to work before 4.4
what can be done?


Are you using File Browser from OpenRepos?

Version 2.5.0 from OpenRepos fixes this and does not use sandboxing.

(It is still waiting for approval in Jolla store. The Jolla store version is also severely limited by sandboxing.)

no it was the official from Jolla store

i just installed the open repos2.5.01 and it is even worse as it says “No permission to read the folder”!!!

/!\ Update the application. It’s easier /!\

There is an error on file /usr/share/application/harbour-file-browser.desktop. It should be :


Instead of :


If you have enabled the terminal you can modify with following command :

sed -i "s/Sandbox/Sandboxing/g" /usr/share/applications/harbour-file-browser.desktop

PR is created. anrisetrnause 20char

thanks but it does not seem to change anything
does one has to reboot ,

It’s fixed in version 2.5.1 (OpenRepos). Restarting won’t hurt but shouldn’t be necessary, I suppose.

1 Like

it is ‘applications’ in the path and on my device there is no ‘Sandboxing=disabled’ in this file.

have i to insert such a line? and where?

You should definitely install the update and I should use more CTRL+C, CTRL-V…

If you don’t want to install File Browser from OpenRepos or wait until it’s available on Jolla Store, if there no [X-Sailjail] section you should add it and then Sandboxing=disabled like this :


But it’s wiser to install the update.

1 Like

I had yet the .rpm of the new filebrowser in the downloads directory.
edit: but I coudn’t install the new FB with the old FB. —
So I deleted the old filebrowser via GUI and then installed the new one with CLI
typing ‘pkcon install-local harbour-file-browser-2.5.1-1.armv7hl.rpm’ as devel-su.

Works + all files and directories are visible and accessible now!

1 Like